I am trying to get cycles to work using hip on a new pc build running Ubuntu 22.04. PC has an AMD Radeon 6800 XT. I downloaded Blender 3.4 through the website and extracted the software in executable form instead of building it myself. The 'out of the box' version worked just fine, but I wasn't able to use HIP for cycles rendering because I wasn't running the right drivers/blender couldn't detect the gpu.

I then install the AMDGPU pro drivers for Linux (released on 12-13-2022), including OpenCL, and confirm that it was installed correctly. [used: amdgpu-install --usecase=workstation --opencl=rocr].

However, installing these drivers now causes Blender to instantly crash. I open the software and I can see it start and open the main window for a fraction of a second before auto-closing.

How do I fix this? Sub-question: how do I run Blender in a debug type mode so I can see exactly what the crash issue is?

  • 1
    $\begingroup$ Under Windows at least Blender setups usually include a command line script to run in GPU debug mode. $\endgroup$ Dec 28, 2022 at 5:07
  • $\begingroup$ Thanks, that helped a lot. Turns out the driver isn't supported, which isn't that surprising I guess since it released 2 weeks ago. Just checked and Blender works with the drivers from late November. Not sure if this is an issue on Blender's side or AMD's side. $\endgroup$ Dec 28, 2022 at 18:04
  • $\begingroup$ Could you post that as an answer below fleshing it out a bit so it stands on its own. That way you'd be more likely to help other users facing the same issue $\endgroup$ Dec 28, 2022 at 23:13
  • $\begingroup$ I will when I can confirm it again. Somehow I stopped being able to install these drivers yesterday and haven't been able to resolve that issue. $\endgroup$ Dec 29, 2022 at 17:00

1 Answer 1


Apologies for the delayed update. I went through a period of being unable to install the AMD proprietary drivers.

When I ran Blender in a debug mode I found that it was automatically quitting because the video driver was unsupported. I don't know if that's an issue with something AMD did or if Blender needs to incorporate the new drivers.

As a test I installed slightly older drivers (ver 22.20 that was released Nov-28) and Blender runs using those.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .