0
$\begingroup$

I'm using Smooth Corrective Modifier to help keep the joints in the mesh on my model from looking ugly but while that fixed one problem it causes another where the Shape Keys for the face get messed up. The image above shows how the face was supposed to look like, but Smooth Corrective Modifier has an error while the image below shows the face a bit deform but Smooth Corrective Modifier seems to have no problem. How do I fix this?

enter image description hereenter image description here

$\endgroup$

2 Answers 2

1
$\begingroup$

Create a vertex group, go to edit mode and select all vertices but the face, select the newly created group in verex troup tab and click Assign making sure all vertices in the group have weight paint of value 1 (set weight bar to 1 before clicking the Assign button).

In Smooth corrective modifier tab, there's a vertex group option, click on that and choose the newly created group.

That way it'll act as a "mask" for this modifier so it wont effect the face and keeps the smooth joints deformation you want.

$\endgroup$
0
$\begingroup$

Using GN (and most conveniently, an extra object) you can do this:

enter image description here

The object on the far right is getting armature deformed and correctively smoothed. Then, it is checking the difference in position between two meshes: one that is armature deformed only, and one that has both a shapekey and an armature. It can then apply this positional difference as an offset.

It could be saving its own position, prior to the corrective smooth, and using that instead of another object; it could even have its own shapekeys stored as GN vector attributes on the mesh, so that no other objects would be necessary. But I think it's easiest to demonstrate using additional, non-rendering objects. In a real-life situation, all three of these objects would be in the same location, parented to the same armature.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .