I am trying to create a tyre that I can 3D print. I tried several methods from various tutorials, but they seem to be meant for animation rather than 3D printing and I always seem to end up with very complex, non-manifiold geometry. They usually involve creating the tyre tread, arraying it around a circle and wrapping it to a surface. The process I have adopted, which has been working, is to create the profile of the tyre from a curve, mirror modifying that over the Z axis, applying that modifier and then use a screw modifier to create the final 'donut'. These modifiers are then applied, so I have a nice, manifold mesh as my tyre carcass. tyre carcass mesh

All good so far. I then created the scallops on the side, arrayed them using an Empty, applied the modifiers, Joined them into a single mesh object. I then applied a Boolean Difference modifier to the tyre carcass and that cut the scallops into the sidewall nicely. scallops before boolean scallops after boolean

I then created my tread mesh from a plane that was extruded and adjusted to create the flat tread pattern. tread mesh

This was then arrayed by rotating an Empty Axis. arrayed tread

That array was then applied, Separated by Loose Parts, Joined back into a single object, and cleaned up with Merge by Distance. The geometry was then extruded along normals in toward the Y axis. extruded along normals

Now, though, when I select neigbouring faces using Command +, I only get a small group of faces, not the entire ring. So it seems the Merge by Distance did not actually join adjacent vertices together. enter image description here When I apply a Boolean Difference modifier to the tyre carcass using the tread loop as the target, I get no result. Boolean modifier activated

I have tried all sorts of things, remeshing, convert to tris, separating and rejoining, converting normals to inside, converting normals to outside, everthing I can think of.

I have even tried separating the parts and then, one by one, joining them together with a Boolean Modifier, applying the modifier, saving the result and then joining the next tread part with another Boolean. Piece by piece. The result was even more confusing. When I applied the Boolean Difference modifier to the tyre carcass, some of the sections worked while others didn't! It still saw the joined sections as separate objects.

It seems to me I am missing some step that will unify the separated, arrayed parts into a manifold whole.

I would appreciate any suggestions as to what to try next!


  • 1
    $\begingroup$ Hello and welcome. It will be hard to pinpoint the source of the problem without access to your blend file. Can you share your blend file? blend-exchange.com $\endgroup$ Dec 24, 2022 at 5:11

1 Answer 1


This part here looks like overlapping geometry.

enter image description here

Check for inside faces between the tread sections. Any intrior faces will cause boolean operations to get upset.

You will probably need to redo the tread array paying close attention to where the arrayed segments meet. Be sure to use the Merge option in the array modifier and increase its Distance until the vertices at the joins merge correctly.

  • $\begingroup$ Thanks, Psyonic, I will experiment with that. The geometry is overlapping, yes, as I was getting gaps before! I will post the results of my explorations. Graubby. $\endgroup$ Dec 24, 2022 at 6:26
  • $\begingroup$ That did it, Psyonic, thanks! I also found out I had duplicated or extruded-in-place the original tread pattern, so there were about five layers of mesh on top of each other. That would not have been helping! $\endgroup$ Dec 24, 2022 at 6:52
  • $\begingroup$ No worries @GrubbyFingers Glad I could help. Could you please mark the answer as correct so others can find it. 😊 $\endgroup$
    – Psyonic
    Dec 24, 2022 at 6:56
  • 1
    $\begingroup$ Hi, @GrubbyFingers ! On SE sites, the way to thank Psyonic is to up-vote his answer,and click the 'answer accepted' tick next to it, if it worked for you.. rather than edit thanks into the post $\endgroup$
    – Robin Betts
    Dec 24, 2022 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .