0
$\begingroup$

I have a set of objects, every object is a line with two vertices.

On one of them I put skin & subdivision modifiers 1 enter image description hereand after that I select the rest > select the object with modifiers > copy modifiers using cmnd+L. They copy in Modifier Properties but visually nothing happens [2]enter image description here.

If I try to just recreate same modifiers on random object without copying – it works [3]enter image description here.

Please help me find the problem:)

$\endgroup$
3
  • 2
    $\begingroup$ Hello ! The skin modifier is sometimes finicky to work with. I think some data is modified on the source mesh when you add a skin modifier via regular means. Select everything in object mode, go into edit mode, then select everything with A, and click on "Mark Root" $\endgroup$
    – Gorgious
    Commented Dec 23, 2022 at 7:39
  • $\begingroup$ On the 2. picture the "Add Skin Data" button not grayed out but on the 3. it is. So the software not generates it automaticaly with this method. If you copy the whole object data, then unlink them, it works, but all of them will be the same (because you rotated the edges in Edit mode, not in Object mode). $\endgroup$
    – FFeller
    Commented Dec 23, 2022 at 17:31
  • $\begingroup$ @FFeller hello! thanks for the answer. I tried to google about copying whole object data (including modifiers) and unlinking it but still not sure what you meant exactly, because there is nothing in Object Data Properties tab to work with. The path with Objects > Relations > Make single user > Object & Data doesn't seem to work either. Could you please describe the order of actions I should do? $\endgroup$ Commented Dec 29, 2022 at 4:26

2 Answers 2

0
$\begingroup$
  1. Select all the objects in Object Mode (one must be active) and Join them
  2. Add the Skin modifier to the new merged object
  3. Go to Edit mode, select everything and press the Mark Root button on the modifier
  4. Separate the loose parts of the mesh (you can add more modifiers before this step so all new object will have them)

enter image description here

$\endgroup$
-1
$\begingroup$

You can try using the letter A to select all objects or select one at a time if. The point is that AT THE END you select the one that has the modifiers and then you can use the command to copy modifiers.

$\endgroup$
1
  • $\begingroup$ I think the problem is that that doesn't work. $\endgroup$
    – Joachim
    Commented Mar 14 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .