4
$\begingroup$

I am having a problem when baking and then using a normal map.

I have a high res and low res model and am using the "Bake selected to active" feature.

I am using BI to bake the image as I cannot seem to get cycles bake to work. I am then applying the normal map in Cycles through a Normal Map node plugged into a Diffuse.

As you can see, the baked image itself looks OK and symmetrical. When I use it, however, half my model seems to have the normals inverted. I previously had a mirror modifier while modelling and I suspect that is involved, but it was applied before I started the bake. I also checked all my normals on the model and they face the right way.

I can't figure it out and its driving me mad! Help! enter image description here

_ _

EDIT: On further investigation I can see that the problem lies with my baked normal map. If you look closely at it you can see that it is not baking correctly as it is uneven. So my bake is wrong, I just don't know why.

$\endgroup$
  • 1
    $\begingroup$ Use CTRL+N in edit mode to recalculate normals. $\endgroup$ – Denis Apr 7 '15 at 20:26
  • $\begingroup$ You could also try to increase a little bit Bias Option just under Selected To Active checkbox before baking. And did you select the Non-Color data in Image Texture node settings for normal map? $\endgroup$ – Mr Zak Apr 7 '15 at 21:01
  • $\begingroup$ Are you using a mirror modifier by any chance? Just a thought, you might want to apply it before baking it if so. $\endgroup$ – VRM Apr 7 '15 at 22:14
  • $\begingroup$ Thanks everyone. I tried these and still have the same problem - though see my question edit. $\endgroup$ – Lewis Apr 8 '15 at 12:34
  • $\begingroup$ you can upload the .blend to PasteAll.org and paste the link here. $\endgroup$ – MarcClintDion Apr 8 '15 at 21:30
3
$\begingroup$

If you made the UV's while the mirror modifier was active then the UV's for both sides should be overlapped, the bake is only correct for one half of the model.

If you hover over the UVImage Editor and press Ctrl+P (Unpack), you should end up with distinct islands for all the geometry.

Now you should re-bake.

$\endgroup$
  • $\begingroup$ Thanks. I applied the mirror modifier before I did the bake though. My UVs are not overlapping. $\endgroup$ – Lewis Apr 8 '15 at 12:30
  • $\begingroup$ Applying the modifier before baking will not un-separate mirrored UV's. $\endgroup$ – MarcClintDion Apr 8 '15 at 21:29
0
$\begingroup$

I have resolved this. The issue was the Non-Color data option for the Image Texture node as suggested by Mr Zak.

My mistake was setting this in the properties panel for node rather than on the node itself (apparently they do not mean the same thing - though I have to confess I do not understand the difference).

Grateful to everyone for the help.

$\endgroup$
0
$\begingroup$

also if you don't want to rebake all of your normal maps just flip the red and green challe in photoshop and you good but don't recommend doing it this way just flip[ the uvs and rebake

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.