1
$\begingroup$

I parented the rig using Empty Groups then weight painted a section. The vertex group seems to not act according to the weight paint and the points all have a weight value of 1.

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

If you parent With Empty Groups, by default the vertices won't be assigned to any vertex group, you need to assign them in Weight Paint mode or with the Assign button.

If you assign a vertex to only one vertex group, even if the weight is very low (like 0.001), the influence of the bone on it will be 100%. So what you need to do is begin to assign the vertices to the other vertex groups, if a vertex is assigned to another vertex group, its weight will be taken into account.

For example if a vertex is part of 2 vertex groups with a weight of 0.001 in both cases, the influence will be shared 50/50 between the 2 bones. If it is part of a vertex group with a weight of 0.1 and of another one with a weight of 1, the second bone will be ten times more influential, etc.

But what you could have done in your case is parenting With Automatic Weights. There's an error message because you have overlapping vertices and very dense topology. To fix that select all in Edit mode and press M > Merge by Distance. Also unparent the object (AltP), shift select the armature, scale both the object and the armature like ten times (S10), it makes the calculation easier in the case of dense topology, parent With Automatic Weights, then scale down to the original size (S0.1).

To give some corrections afterwards, select the armature in Object mode, shift select the object, switch it to Weight Paint mode, select the desired bone and paint.

$\endgroup$
8
  • $\begingroup$ And how do I assign weight to vertex groups ? $\endgroup$ Dec 11, 2022 at 11:45
  • $\begingroup$ Exactly like you are doing it right now: Select your armature, shift select the object, switch to Weight Paint mode, select a bone, paint, select another bone, paint again, and so on. You also could have tried a parentage With Automatic Weights, and if you ever have a correction, it is the same method $\endgroup$
    – moonboots
    Dec 11, 2022 at 11:52
  • $\begingroup$ When parenting with automatic weights it showed : "Failed to find solution for one or more bones" So I have to weight paint without parenting the mesh to the armature? or using another parenting option ? $\endgroup$ Dec 11, 2022 at 12:15
  • 1
    $\begingroup$ It means that there's a problem with your mesh, could you please share the file? blend-exchange.com $\endgroup$
    – moonboots
    Dec 11, 2022 at 12:22
  • 1
    $\begingroup$ It makes the calculation easier in case of dense topology $\endgroup$
    – moonboots
    Dec 11, 2022 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .