0
$\begingroup$

I've assigned an emissive material to parts of an object in a scene. The rendered view inside the viewport looks fine but the final render doesn't. Somehow, the emissive material goes beyond the faces I've assigned the material to - and only in my renders.

I've attached stills to illustrate the problem. I've checked everything but I don't know what's wrong.

Thanks.Rendered Mode inside Viewport

Rendered Image

$\endgroup$
3
  • 2
    $\begingroup$ Do you use Subdivision surface? It could be, that your rendered SubD settings are higher than the viewport one $\endgroup$ Commented Dec 8, 2022 at 8:59
  • $\begingroup$ Great ! That was it :) Thanks a lot ! $\endgroup$ Commented Dec 8, 2022 at 9:03
  • $\begingroup$ Your welcome :) $\endgroup$ Commented Dec 8, 2022 at 9:13

1 Answer 1

1
$\begingroup$

Whenever render and viewport results are different, check for:

  • different settings in modifiers for viewport and render
  • hidden objects, collections, lights
  • sampling settings
  • collection settings (e.g. holdout, indirect only)
  • renderlayer settings
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .