1
$\begingroup$

Houdini user here. In Houdini when we load alembic files, it just reads from disk.
Meaning when you save your Houdini scene, the alembic won't increase the file size because it just reads it from disk.

In blender when I import my alembic scene, file becomes really big because it is saving the alembic in my blender file.

I found a work around, if I create a default cube and append a mesh sequence cache modifier then find my alembic cache/object path, it will reference rather than import. Once my scene is saved the .blend file will stay the same.

My question is why does this method work, but not the first method? They both do the same thing (assuming you have use mesh cache sequencer modifier enabled on alembic import settings).

Is there a way to get the importer to work in the way I want so I don't have to manually set it up?

thanks!

$\endgroup$

1 Answer 1

0
$\begingroup$

When you are importing .abc file enable in popup window under properties Always Add Cache Reader.

enter image description here

Like that all imported objects will be linked from disk. By default only mesh sequences are linked (those are mostly the most memory consuming objects) and the rest of objects (that can be handled natively in Blender) is appended, so you can modify them without any limits.

$\endgroup$
3
  • $\begingroup$ Yea, that was part of my question. Even after enabling it my scene got bigger. so I was confused on why my scene got bigger when I did file import vs manually setting it up even though the end result of the setup appeared to be identical. $\endgroup$
    – evanrude
    Commented Dec 9, 2022 at 11:06
  • $\begingroup$ Can you share your file ? For now I can't confirm that. I imported 114 MB .abc file and saved .blend was 0.9 MB ... it works for me ... isn't it that you work with the same file so there is a chance data was kept inside .blend file after delete? Blender keeps for one or two other saves abandoned data still inside a file. Try import .anc into a new .blend. $\endgroup$
    – vklidu
    Commented Dec 9, 2022 at 11:16
  • $\begingroup$ youtu.be/3ppjPGCb9so short video of my doing both methods and saving it. As you can see, using the import causes the scene file to get bigger even when use mesh cache. $\endgroup$
    – evanrude
    Commented Dec 9, 2022 at 22:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .