0
$\begingroup$

Recently I was working on creating an animation in Cycles Render, and my camera started showing only gray when I switched from the Camera View (by toggling 0) to the User Perspective. Similarly, if I try to move orthographically within the Camera View it shows only gray; here the location numbers become enormous (again, not sure why) but this doesn't occur in the User Perspective and it remains gray. I tried to find a solution to this on the site, but the common problem and solution seems to be with clipping distance, and mine seems to be large enough. I think I toggled something by accident, but I can't determine what. The screenshots are of the different views.

all is well

chaos

same problem, same distance

$\endgroup$
6
  • 1
    $\begingroup$ It looks from your second screenshot like your camera is too far away to be included in the clipping distance. There is a huge difference in camera location between the two screenshots. $\endgroup$
    – Denis
    Commented Apr 5, 2015 at 7:23
  • $\begingroup$ I tried taking a look at the distance to see if I could resolve it, but now the gray screen appears with the same distance numbers as the correct version. I added another screenshot to show this $\endgroup$
    – lavajava31
    Commented Apr 5, 2015 at 16:07
  • $\begingroup$ ok so I've played around some more and the same thing happens through all the layers, if that's a clue. I tried locking the Location and Rotation, and the problem appears to be with the Location. In the Camera View, I can lock the Rotation and then when I zoom in or out the Location shifts to numbers in the hundreds of millions. However, I have not discovered anything else with regards to the User Perspective $\endgroup$
    – lavajava31
    Commented Apr 5, 2015 at 16:16
  • $\begingroup$ can you post your blend file? $\endgroup$
    – Denis
    Commented Apr 5, 2015 at 17:53
  • $\begingroup$ It looks like you have some keyframes which are moving the really far away from the scene, requiring an insanely huge end clip value.. $\endgroup$
    – gandalf3
    Commented Apr 5, 2015 at 20:31

2 Answers 2

2
$\begingroup$

You have to right click on Layout of your project and click Delete. And if you want back your layout click on + button and general and layout

And your problem is solved

I think it is a glitch with that layout so you have to delete it and create another.

$\endgroup$
1
  • $\begingroup$ This worked for me on 3.4.1 $\endgroup$
    – Fede Berg
    Commented Sep 27, 2023 at 16:38
1
$\begingroup$

From your snapshots it looks like your camera shifted a very long distance, try to adjust the camera location or the camera clipping.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .