0
$\begingroup$

I'm fairly new to Blender, and I'm using it to mock up some assets for my YouTube channel. I found a tutorial on YouTube for a really nice neon light effect, and I've been trying to make a logo using it. Up until this point everything has worked perfectly.

The problem arose when I tried to create a version of the logo with a transparent background (for thumbnails, etc). I changed the render settings for the background, then played around with the alpha settings in the node viewer until I got what I wanted:

The node editor

When I render it out and view the result in the image viewer, I get the following:

The render

So far so good, right? The issue comes when I try and save this render. Here are the settings I've been using (I've varied a few of these, to no avail):

My render settings

Invariably, when I try to view the image in my default image viewer, this happens:

A blank screen

The image is completely invisible, and I don't have any idea why this might be the case. If I switch the color settings to RGB then the image renders how I want, but with a black background instead of a transparent one, so it must be a problem with the alpha.

Any help would be greatly appreciated!

$\endgroup$
0

1 Answer 1

-2
$\begingroup$

Stop. Using. PNG.

It is a garbage broken encoding.

And then once everyone learns about how flawed of a file encoding it is, work on getting the default file save option changed.

(I strongly suspect all eight bit file encodings in Blender are still a broken mess. This leaves you with exactly one option for encoding alpha in Blender, and that is EXR. This too is sub-optimal, but until file encodings are fixed in Blender, it is your only option. Once they are fixed, you will be able to use TIFF properly.)

$\endgroup$
3
  • $\begingroup$ I have re-rendered the image and saved it as an OpenEXR file. The problem persists - my laptop prompts me to open it with Photoshop, whereupon I'm presented with two options: alpha as alpha, or alpha as transparency. The former creates an entirely transparent image, the latter gives me the desired image but on a black background. $\endgroup$ Commented Dec 7, 2022 at 16:52
  • $\begingroup$ If I save the image as a .tif, something even stranger happens. In the default photo viewer, it appears exactly how I want it, i.e. an image with no background. However, as soon as I try to open it in any external program (Photoshop, Word, Illustrator), it instead opens as a completely transparent image. $\endgroup$ Commented Dec 7, 2022 at 16:56
  • $\begingroup$ You are hooped if your hope is to take it into another piece of software. Most software cannot interpret the correct application of alpha, but worse, Blender does not encode it correctly into any image files except for EXR, which is not going to be ideal as it will be missing the picture formation component. Blender needs to fix its alpha on file encodings. It’s been wrong for a decade and a half, and Photoshop also happens to be a broken mess. $\endgroup$
    – troy_s
    Commented Dec 8, 2022 at 0:25

Not the answer you're looking for? Browse other questions tagged .