2
$\begingroup$

I'm very new to Blender, having just started yesterday, and my render is lacking the sharpness I'm expecting it to have.

I'm rendering a simple textured dodecahedron to a PNG of 192x192 pixels, with a transparent background.

Depth of Field is turned off (unchecked).

I'm rendering in Perspective lens with a 450 mm Focal Length. (note: I've also tried rendering with a camera half as far and half the Focal Length, but got the same softness)

I have "Render Properties -> Sampling -> Render" set to 16 samples. (this is identical even if I set to 128 or the default of 64 - identical render result)

I've set the Texture Interpolation (texel sampling) to Linear, Closest, and Cubic, and it didn't make a substantial difference to my final result.

When I render at 512x512, it gives a nice crisp image like I am expecting. I can then open that image in Paint Shop Pro (an art program) and resize it with Paint Shop Pro to give a 192x192 image that is still nice and sharp. (Note: PaintShopPro has multiple resizing algorithms, but two different algos I tried both gave sharper results)

Yet, if I render it at 192x192 directly in Blender, the image is far far softer (less sharp) than I would expect.

I suspect I have some setting wrong somewhere, but don't know what to look for.

enter image description here

$\endgroup$

1 Answer 1

3
$\begingroup$

Eevee fights aliasing by rendering multiple times with slight camera offsets. Those offsets are defined in pixels, not by percentage, so changing output resolution will change the offset:

Try setting it to $0.56$ px, as then it will reflect the change of your output resolution:

$${512\over192} = 2{2\over3}$$ $${1.5\over0.56} \approx 2{2\over3}$$

$\endgroup$
1
  • $\begingroup$ Thank you, this was exactly the issue! $\endgroup$
    – Jamin Grey
    Commented Nov 29, 2022 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .