1
$\begingroup$

When I render a deformed cube using the Cycles engine, an extra vertex which crosses the top of the shape diagonally is processed. This vertex does not appear in Edit mode. How do I stop the engine from "halving" the face?

Extra vertex in Cycles render

$\endgroup$
2
$\begingroup$

What you have is an extra edge. From what can be told from the picture, the positions of the vertices forming that face are not flat, and so you are asking it to make an impossible shape. You cannot have a square with diagonal verts at different heights that do not create a flat plane. It is showing the triangle because you are asking for something that is not possible.

Smooth shading may help. But for the shape you want, you need more geometry for it to be possible.

$\endgroup$
1
$\begingroup$

Looks like the the vertices of that surface are not co-planar. This breaks the face and to solve it blender displays 2 tris putting the new virtual edge were it finds most convenient. In edit mode you can't see it just because the shading is not very detailed, but if you turn on ambien oclusion (version 2.74) it will show.

You can enter edit and make the 4 vertices co-planar or e to add an edge and set it to shade smooth. But if you want more control of the curvature you will need to add more geometry.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.