1
$\begingroup$

I am making an animation that follows the "grow grass in Blender 2.8" tutorial for the floor plane. There is more going on in the scene, but all of that is working properly.

In viewport, the hair particles are visible, though sometimes their number is displayed improperly (fixed by playing the animation in viewport).

In render, the particles are visible ONLY if I keep the sphere object used to emit the particles (from the 2nd tutorial) visible in the render, which is undesirable. Otherwise, the hair particles show up in very few frames of the rendered animation (5/100) random.

Here are my render and hair particle settings:

all used settings

And here's the render settings:

altered render settings

Here's a sample of the renders w/ the grass "flash":enter image description here

Thank you so much!

New contributor
Poot is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
$\endgroup$
4
  • $\begingroup$ To clarify, you can't use the 'Show Emitter' checkbox because of this? $\endgroup$ Nov 25 at 0:28
  • $\begingroup$ @AllenSimpson no, the box is checked! Everything seems to be working fine on paper..? Even still renders tend to get the hair show up more often than not, but animation glitches. I will try again to see if this was a bug of sorts, but it has been rather persistent until now. $\endgroup$
    – Poot
    Nov 26 at 17:08
  • $\begingroup$ I mean if you uncheck show emitter it should not appear in renders, and you could keep the extra object in your scene with no problem. Check the objects in the outliner to see whether you accidentally keyframed visibility. $\endgroup$ 2 days ago
  • 1
    $\begingroup$ Yes, that solution ended up working! Because I had the sphere object that was acting as the brush for the canvas disabled in render but still had the "show emitter" tab on, it was acting glitchy. Once I turned on render visibility for the object and unckecked emitter, it was working. Thank you Allen!!! $\endgroup$
    – Poot
    yesterday

0

Your Answer

Poot is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.