5
$\begingroup$

For some reason when I use the active render in my viewport everything is shown as it should. Then when I actually render the image some of my objects are shown as completely white.

I can't for the life of me figure out why. One of my objects has a texture as well that works perfectly in the viewport render but when I render the scene not only does it show up as only white but it shows no texture whatsoever.

Please help. I've searched through many forums and have not been able to run across anyone else having this problem.

Here is a sample:

$\endgroup$
  • $\begingroup$ in the render_layers tab there is a material it should be empty, it is used to replace all materials in this layer $\endgroup$ – Chebhou Apr 2 '15 at 14:12
  • $\begingroup$ Yes, I saw that some people were having a problem akin to mine but I did check that and it is indeed empty. My problem lies somewhere else... $\endgroup$ – Joe4556 Apr 2 '15 at 14:29
  • $\begingroup$ I don't mind posting some pictures as maybe that would expedite things and help those gracious enough to try and help me find a solution to this problem. I don't however know how to post pics... Also I wouldn't mind posting my blend file either but it is a fairly complicated scene (in excess of 80mb) and I read on pasteall that the cap is 30mb $\endgroup$ – Joe4556 Apr 2 '15 at 14:32
  • $\begingroup$ when you are editing your question you'll see small picture click it to upload one, for the blend file remove almost everything except some objects to demonstrate the problem and upload it on blend-exchange $\endgroup$ – Chebhou Apr 2 '15 at 14:35
  • $\begingroup$ ok here is a simple blend file. <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=149" /> $\endgroup$ – Joe4556 Apr 2 '15 at 14:46
2
$\begingroup$

One of the objects was hidden in the view but visible in the render , you have to uncheck the camera icon in the outliner :

enter image description here

the render layer didn't include all scene layers, excluding some objects from the final render, for this you have to check these layers in the render-layers tab :

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.