So tried to do these :

  • Did it all over again in case i forgot to bake mesh maps at the first try.
  • Used a node wrangler by CTRL + SHIFT + T

Did not work.

This is how it looks at Substance :

This is how it looks on Substance

Full screen :

This is the full screen on Substance

How it looks when I export to Blender :

This is how it looks on Blender

Full screen on Blender :

Full screen on Blender

Export full screen on Substance :

Substance export screen

Any help is appreciated.

  • $\begingroup$ The bluish gray color what is missing in Blender is came from the metallic map and the skybox in Substance Painter. You have 0 metallic in Blender. $\endgroup$
    – FFeller
    Commented Nov 23, 2022 at 16:53
  • $\begingroup$ @FFeller That was kinda poor grammar, but what I think you meant was that there is no world texture set up in Blender, and that the material’s Metallic setting needed to be turned on. The first one is clearly false: Look at the background, it’s textured green-ish. Even if that is just Material Preview, reflections of the sky should be visible there. The second one is true, though. $\endgroup$
    – TheLabCat
    Commented Nov 23, 2022 at 17:08

1 Answer 1


The material set up in blender is wrong. This has been typical of importing models from other programs into blender, since how materials work is pretty program specific.

  • The image plugged into Base Color looks like it is actually a Roughness map. Set it from sRGB to Non-Color, and connect it appropriately.
  • Turn Metallic all the way up.
  • The Mapping node is not necessary since it is set to no alterations, and can be deleted. The Texture Coordinate should not be necessary either, since you are using all image textures, which default to using a UV map if there is no Vector input.
  • 1
    $\begingroup$ Thank you so much. It worked. $\endgroup$ Commented Nov 24, 2022 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .