1
$\begingroup$

So I'm working on this scene in blender cycles. The scene consists of an underwater setting, where the camera dives to the bottom. I have two lights: the sun and an area light. The brightness of the sun is set to 70 and the area light is set to 4000W. There's a cube with basic principled volume property applied (Density 0.5 & Anisotropy 0.3) and this object is supposed to emulate the ocean/water depth as the camera goes down, The object also receives caustics applied in the object data property. Under the rendered viewport, the lighting looks perfect with the light fading as it goes down but upon rendering the frame, the whole scene looks dark.

image 2: Render preview viewport image 1: Materials preview viewport image 3: Rendered frame (not completely rendered but tried rendering one completely and looks the same - dark) enter image description here enter image description here enter image description here

It'd be great. if you guys could weigh in on this.

best, AJ

$\endgroup$
3
  • 2
    $\begingroup$ Hey AJ, would you please upload your Packed Blender.file to blend-exchange.com $\endgroup$ Nov 23, 2022 at 10:16
  • 1
    $\begingroup$ Two things: the Material Preview is not very good in showing the correct result of volumetrics. This looks as if your density is too high - I would adjust it in rendered view. The other thing is, I'm quite certain that in the Render Properties > Light Paths > Max Bounces the value for Volume is 0 (to decrease render time by default). In order to make the volume not so very dark, light needs to be scattered and bounced around in the volume, which doesn't with 0 bounces. I would at least set it to 1 maybe 2. Check these two things, I don't think uploading a file is necessary. $\endgroup$ Nov 23, 2022 at 10:19
  • $\begingroup$ @EvripidisLalissidis Thank you so much for replying to my question. I couldn't upload it to the link because of the file size. I've attached the blender file in the link here: drive.google.com/drive/folders/… $\endgroup$
    – Jassim
    Nov 23, 2022 at 12:08

1 Answer 1

3
$\begingroup$

Here are a few points which are the reason that your volumetrics don't look bright enough:

  1. Your expectations are misled from the Material Preview, it is not an accurate representation of what the volumetrics would look like when rendered.
  2. The main difference is, the density isn't shown correctly, it will look much more dense in render than in preview.
  3. The Anisotropy value of 0.3 makes it look darker than a value of 0.0 - it's subtle, but it has an effect.
  4. The Absorption Color in the Principled Volume shader is black. If you would also set it to the main Color (the scatter color), the volumetrics would be brighter, too.
  5. The Max Bounces for Volume are probably 0 (which is the default). Increasing this value will increase render time, but brightness, too. I would at least set it to 1 when you are using volumetrics.
  6. Last bout not least: the bright sunlight shines down so the stairs throw very dark shadows onto themselves (which aren't lit up by bouncing light due to the value of 0, see point 5).
  7. PS: I almost forgot, the brighter the color of the volumetrics, the more light gets scattered and therefore the more it obstructs the view on the stairs.

So first of all, 0.5 is already a quite high density, depending on what look you want to achieve something like 0.05 might be absolutely sufficient:

density

Next up a comparison of the anisotropy influence, I used a higher value of 0.6 to make the darkening more visible - but on the positive side, it can reduce noise:

anisotropy

Here an example of using the water blue for the Absorption Color. Note that this might change the overall tint of water as well, but you don't have to use the same colors, you can experiment with this. The brightening effect will be stronger, the brighter the color and also Volume bounces > 0 will help (see the following example):

absorption color

The Max Bounces for Volume increase the brightness inside the volumetrics as well by scattering the light more. Unfortunately this will increase render times and noise. But it is also very helpful if you have an Absorption Color brighter than black (not pictured here):

volume bounces

The last image on the left shows the volumetrics now with all earlier changes applied, lower density, anisotropy reset, absorption color and volume bounces at 1. But as you can see, since the light gets scattered strongly by the bright blue, it obstructs the geometry further back a lot. In comparison to that the right side shows volumetrics with all the same settings but a darker blue for scattering and absorption. But if you want to keep the color, the same or at least a similar effect can be achieved by further decreasing the density.

darker blue

$\endgroup$
4
  • $\begingroup$ Hello Gordon, Thank you so much for your comments. I followed some of the points that you mentioned earlier before uploading the pictures. I have attached my project file in the link below. Can you check it out and advise me on what's wrong with the project? because even with the changes they look the same. drive.google.com/drive/folders/… $\endgroup$
    – Jassim
    Nov 23, 2022 at 12:23
  • $\begingroup$ @Jassim I looked at your file, but first of all, one of the important changes wasn't made in the file - the density was still at 0.5 which is much too high, this reduces the strength of light coming through a lot. But whatever you do - I don't know if you'll ever get exactly what you want. If you reduce the density, you can see through the "fog" (that's what it is in fact) much clearer. But less density means less scattering of light, so the dark shadows from the very bright sunlight won't get illuminated as much and are darker than with a higher density fog. $\endgroup$ Nov 23, 2022 at 12:46
  • $\begingroup$ thank you so much for taking the time to go through my project file. I corrected them and still look the same and dark. What I don't understand is that in rendered viewport it looks perfect but while rendering the frame it's a whole different thing. $\endgroup$
    – Jassim
    Nov 23, 2022 at 15:34
  • $\begingroup$ @Jassim You have an object above the volumetric object called "Plane", it seems it's a wavy ocean surface. This is made invisible in the viewport, but visible in render. The material is blue glass, I'm quite sure this takes away a lot of light for everything below it. $\endgroup$ Nov 23, 2022 at 18:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .