1
$\begingroup$

I configured a world with nodes in Blender and I'd like to rotate it along the Z axis.

A world displayed through a camera with a high FOV.

Unfortunately, as soon as I connect a Mapping and Geometry node, my camera's Focal Length and Sensor Size settings no longer affect the image.

My node setup.

The world without high FOV.

Is there any way to retain my field of view settings while having the Geometry and Mapping nodes attached?

You can find the .blend file here!

$\endgroup$
2
  • 1
    $\begingroup$ Try texture coordinate -> generated instead of geometry -> position $\endgroup$ Nov 17, 2022 at 20:34
  • $\begingroup$ That worked, thank you so much!!! $\endgroup$
    – MEATTAIL
    Nov 18, 2022 at 9:35

1 Answer 1

1
$\begingroup$

The solution was to replace the "Geometry" node with a "Texture Coordinate" node!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .