So I am rendering this character. For some reason it's rendering black but in Look Dev it shows the proper texture. Why?

enter image description here

enter image description here

  • $\begingroup$ maybe you have overlapping faces, please check or share your file: blend-exchange.com $\endgroup$
    – moonboots
    Nov 13, 2022 at 12:44
  • $\begingroup$ @moonboots Added. $\endgroup$
    – Ted
    Nov 13, 2022 at 12:57

1 Answer 1


You have given thickness to your object, you have 2 meshes almost overlapping, one with black color faces, the other with colored faces. The mesh with black faces has its faces inverted. As you've enabled the Backface Culling option in the Material > Viewport Display, we can't see these black faces in Material Preview, only the colored ones beneath.

To fix that, either remove the black mesh, or, if you need to keep them for some reason, select all your pieces, switch to Edit mode and recalculate the normals.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.