0
$\begingroup$

I'm trying rendering and VFX for the first time, and I got the Motion Tracking to work and but whenever I try to render the video or go into the rendered view it doesn't show the video. Here's a screenshot of the nodes and settings:

Left: Compositor, Right: Rendered (Video not showing), Bottom: Background Video

The weird thing is that when I actually try to Render it doesn't even show the object (which does have a light source). The video, cube and camera is set as foreground and the sun is set as background:

When I hide the camera the video hides, so I think the video is a child of the camera

Also I'm pretty new to Blender, so thanks for any help. :D

$\endgroup$

1 Answer 1

0
$\begingroup$

Probably there is something in the VSE (Video sequencer editor), which is overriding the render as post process.

To solve, disable the VSE from post process pipeline (as you're using compositor only).

enter image description here

To check your compositing, enable the "Backdrop" button top right in the compositor window.

$\endgroup$
5
  • $\begingroup$ Thanks for answering! That did help, but now I have a weird problem where I have both layers (the thing I'm adding and the video) connected to the Alpha Over node, but it only ever shows the one connected to the bottom Image slot, and only one at a time. Also, sorry, I'm not sure I explained that the best, haha. :) $\endgroup$
    – Redical
    Nov 13, 2022 at 11:46
  • $\begingroup$ Hard to tell, maybe you can upload the file, it should work out of the box, even if you don't need two different render layers, as you're compositing one render layer over one movie file. $\endgroup$ Nov 13, 2022 at 12:06
  • $\begingroup$ Hmm... how would I do that? Sorry, this is the first time I've ever used the Compositor, haha. $\endgroup$
    – Redical
    Nov 13, 2022 at 12:15
  • $\begingroup$ just delete background layer and in foreground layer enable sun too. Your background is the movie, the compositor tree looks ok. $\endgroup$ Nov 13, 2022 at 12:24
  • $\begingroup$ Thanks for the help! I messed around with the nodes for AGES, but it turned out all I had to do was render it once and the Compositor realized that it was supposed to be showing both. $\endgroup$
    – Redical
    Nov 14, 2022 at 0:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .