0
$\begingroup$

I have a problem with shadows (still new to blender).

While playback, shadows appear in the viewport but when i render out (single) images there is no shadow visible in the rendered product. It seems like they "fade away". Maybe it has something to do with the intensity of the shadow - like it is not dark enough for the final render?

Does anyone know how to fix this? Thanks very much!

shadows displayed in viewport while playback

shadows faded away when playback paused and not visible in render

$\endgroup$
6
  • $\begingroup$ soft shadows is on? $\endgroup$
    – Crantisz
    Commented Nov 7, 2022 at 9:56
  • $\begingroup$ @crantisz I'm actually rendering in cycles. It seems like you can not choose soft shadows in cycles? the shadows are not rendering too bad in eevee but in cycles they all vanish in the render. thanks for the quick answer btw :) $\endgroup$
    – zopavelina
    Commented Nov 7, 2022 at 10:15
  • $\begingroup$ I thought you are using EEVEE. But I see images only from viewport. Is use lights in viewport settings is checked? $\endgroup$
    – Crantisz
    Commented Nov 7, 2022 at 10:19
  • $\begingroup$ yes, scene lights is checked in viewport. $\endgroup$
    – zopavelina
    Commented Nov 7, 2022 at 10:32
  • 1
    $\begingroup$ Hm. Maybe share blend file then? $\endgroup$
    – Crantisz
    Commented Nov 7, 2022 at 11:00

1 Answer 1

0
$\begingroup$

So, I see this light called "Point" produce shadows. You can see them in EEVEE preview, but not in Cycles.

enter image description here

To make it clear, I increase power 10 times:

enter image description here

Now, lets' switch to Cycles. I can see that light itself doesn't work. Not only shadows:

enter image description here

EEVEE doesn't use shader nodes in light, but Cycles does. So that this node setup disables the light because no node is connected to light output:

enter image description here

So let's switch off the nodes:

enter image description here

Now light is coming, but still no shadows. It is because they are so soft, so you can't see them.

This circle indicates the size of the light. The more size compared to objects, the softer the shadows.

enter image description here

So let's decrease the radius. With radius 0, you can see sharp shadows:

enter image description here

To summarize two things here:

  1. Light is disabled because of wrong node setup.
  2. Shadows are soft because of huge light size.
$\endgroup$
1
  • $\begingroup$ ooh i see now what happened. at one point i edited the light nodes for the point light trying to solve the problem, then undid it and forgot to take out the nodes again. thank you so so much for your help and saving me! $\endgroup$
    – zopavelina
    Commented Nov 7, 2022 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .