0
$\begingroup$

Here is my view: view

I want to make the floor less dark so my wireframe objects are not the same color as it. I tried setting the background color on the world, but that has no affect.

I searched the Internet, but that only told me how to change the color of the grid lines and none of the other preferences seemed to do what I want.

Anyone know how to do this?

In his answer to this question, Abraham Reinhardt showed me his Viewport Shading menu, but mine looks like this and does not have the same settings as his: enter image description here

In a comment, Blunder suggesting setting the world background and strength. I tried that and it did nothing. Here is the menu I am editing:

enter image description here

Abraham Reinhardt also suggested changing the Viewport Display color, but that did not change anything either. Here is a pic: enter image description here

$\endgroup$
6
  • 1
    $\begingroup$ hello, what floor are you talking about? also, maybe share your file so that we can try $\endgroup$
    – moonboots
    Commented Nov 5, 2022 at 15:11
  • $\begingroup$ There’s no such floor in blender. The dark gray background you are seeing is the world background. I don’t know what setting you tried to change, but that color should change in viewport render (which is the viewport mode you are in) when you adjust the world shader color. $\endgroup$
    – TheLabCat
    Commented Nov 5, 2022 at 15:18
  • 1
    $\begingroup$ In the World settings you have set a bright color which is visible in the Rendered viewport shading mode (key Z). That's correct. But you have set the Strength to 0 which results in darkness. Set World Properties > Surface > Strength to 1. (I only wonder why it's not pure black in your screenshot) $\endgroup$
    – Blunder
    Commented Nov 5, 2022 at 15:20
  • 2
    $\begingroup$ @moonboots -- I believe Neil is talking about a color in the "Preferences >> Themes >> 3d Viewport" ... somewhere... $\endgroup$
    – james_t
    Commented Nov 5, 2022 at 15:21
  • $\begingroup$ @Blunder I set the I am in the rendered viewport. I set the strength to 1 and the color to red, but the view did not change. I can't figure out how to add an image to this comment so I will edit my original post to show the menu I edited. $\endgroup$
    – Neil
    Commented Nov 5, 2022 at 20:28

2 Answers 2

1
$\begingroup$

You are using a rendered viewport, with Scene World disabled.

I include an example where I enabled Scene World, that then uses the World color/nodes:

enter image description here

And then in World Properties -- with Use Nodes enabled -- I changed the background color:

enter image description here

Of course, as the world color may be reflected off of the other objects' materials, it will affect their color also. But some variant of white shouldn't mess you up too much!

$\endgroup$
4
  • $\begingroup$ Yes it's a workable way in Rendered mode with Scene World checked. He still said it didn't work maybe he want that unchecked? I'm not sure. But I find another way inspired by your answer. Since comment cannot post image I'll edit my answer. $\endgroup$ Commented Nov 6, 2022 at 8:33
  • $\begingroup$ When I check the Scene World checkbox, it changes the color of everything in my scene. That is not what I want. I only want to change the color of the floor itself. $\endgroup$
    – Neil
    Commented Nov 7, 2022 at 4:49
  • $\begingroup$ @Neil -- it doesn't actually change the material colors on your other objects, but rather is like blending colors, as if you changed/colored your room lighting. If you want a dark background (object), your only choice is to create a object (e.g., plane mesh) "behind" your other objects, and use a material with your color of choice. $\endgroup$
    – james_t
    Commented Nov 7, 2022 at 15:22
  • $\begingroup$ @james_t I think you are right. I will have to design my own workaround. Blender won't give me what I want to do. $\endgroup$
    – Neil
    Commented Nov 7, 2022 at 19:14
1
$\begingroup$

There's a way to change background color that can be seen and only in Solid mode. Switch "Theme" to "Viewport" and change the color below.

enter image description here


Inspired by james_t's answer. There another way to do it in Rendered mode with Scene World unchecked. Go to World Properties and change the Viewport Display - Color.

enter image description here

$\endgroup$
4
  • $\begingroup$ The needle in the haystack was found ! $\endgroup$
    – james_t
    Commented Nov 5, 2022 at 20:00
  • $\begingroup$ My interface is different than yours, I could not figure out how to add an image to this comment so I edited my original post to add it. $\endgroup$
    – Neil
    Commented Nov 5, 2022 at 20:20
  • $\begingroup$ It's because mine is using Solid mode and can only be used in Solid mode whereas yours is in Rendered mode. I'm sorry that this solution does have its limitation. $\endgroup$ Commented Nov 6, 2022 at 8:28
  • $\begingroup$ @AbrahamReinhardt I see what you are saying, I did not realize the drop down box was relevant in all the modes. Unfortunately, Solid mode makes all my objects gray and translucent. That is a bigger problem. Also, I tried going to World Properties and setting the Viewport Display color and it did not change anything either. I will add a picture to my original post. $\endgroup$
    – Neil
    Commented Nov 7, 2022 at 4:42

Not the answer you're looking for? Browse other questions tagged .