0
$\begingroup$

I started learning blender 2 months ago. . Everything was fine till I rendered it, after it rendered I noticed that the plane on which the bulbs were becoming bumpy and distorted in shadowy areas I think, I tried different things to fix it by turning clipping distance, changing f-stop and changing sample data and denoising but nothing. the problem only appears in the rendered image not in the viewport which makes things even more difficult because it takes hours to render a single image on my pc please can anyone tell me how to fix it this the rendered image Look at this I Edited the image to show distortion as you can see the image has distortion in the shadows I marked it with a pen as you can see the white area has very low distortion, the yellow has a little distortion and the red area has a very high distortion. can u please help and tell me what's wrong with it?

$\endgroup$

1 Answer 1

1
$\begingroup$

That "bump" is the result of a denoiser not having enough samples to produce a good result. If it only appears in the rendered image you need to make sure you have both denoising checkboes - under "Viewport and "Render" - unchecked. The denoising checkboxes

That solves the "bumpiness" but might still leave your image noisy. Usually I would suggest enabeling the "denoising data"-passes and plugging them into the denoise node of the compositor, but i'm not sure that this will produce good results with all the glass in the scene. In that case increasing the sample count will do the job as well, just slower.

$\endgroup$
2
  • $\begingroup$ You say yourself the issue is the "denoiser having not enough samples to produce a good result", yet your solution isn't to play with the samples but instead deactivate the denoising? That sounds weird to me. I would definitely increase the min samples and also the max if necessary. Maybe also the max bounces. For the denoise options itself, I would leave it to the default options: OpenImageDenoise, Albedo and Normal passes with Accurate prefilter. That's the same as using the Denoise node in compositing, minus the need to plug all the nodes sockets and redo a render with the right passes. $\endgroup$
    – L0Lock
    Nov 5, 2022 at 1:47
  • $\begingroup$ Well, he wants to get rid of the bumps - and deactivating the denoiser is the fastest way of achieving that, even if it reveals the noise underneath. If that's acceptable, we're done here. The settings in the image don't relate to my post - it's just there to show where the option (marked in red) is. I do still mention that increasing samples is an option later on. That the denoiser in the settings now matches the node however is nice - i didn't know that. $\endgroup$
    – Ismir Egal
    Nov 5, 2022 at 23:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .