0
$\begingroup$

Post 1:

I have made a comp (original comp - top image below). I've rendered the composited CG element out as a tif sequence RGBA 16 bit no compression. I've had to do this because there are multiple instances of it, if left as one comp its too much and takes too long to render.

When I reimport the rendered CG element tif sequence back in there's a distinct lack of colour or definition, I've tried changing the colour settings but to no avail (second image, RGBA layer view on top left, new comp below it), even if you look at the RGBA preview it looks more defined compared to the second comp but still way off the original, it looks nothing like the original composited image. If I change the new comp to filmic view transform under the Eevee settings it just greys out the CG element making it appear more transparent and more desaturated, the settings as they are in the below image represents the closest I can get to the original at the moment.

Can anyone please advise?

enter image description here

enter image description here

$\endgroup$

5 Answers 5

1
$\begingroup$

The best way to store images with transparent glow etc. is using the OpenEXR format. When you set the codec to DWAA there is no noticable quality loss although it's a lossy format and the best thing is, the file sizes are very small compared to PNG and especially 16-bit TIF.

If you input the image as OpenEXR, Blender usually sets the Color Space to Linear and Alpha to Premultiplied by default. This way you're good to go and compositing it over a background looks the same as if you would have composited immediately while rendering the image.

Here are some comparison images, the first is the original render composited directly together. The next is what the saved TIF file looks like when opened in Blender and the result when you Alpha Over it on the background. The last is the EXR version - there is no difference to the first result.

The other thing is, effects like glow etc. who depend on bright emissions that are maybe exceeding the 0 to 1 range of the sRGB colors doesn't even have to be composited before saving to EXR, this was just for demonstration. You can do this afterwards on the EXR since the emission brightness is stored correctly as well.

And the last: the 16-bit TIF file I saved has a size of 3.96 MB, while the 32-bit EXR only needs 136 kB, that's even less then the final composition as 8-bit PNG file with 759 kB.

original

tif

exr

$\endgroup$
0
$\begingroup$

Post 2:

Thanks for the detailed explanation. I had gone back to the comp to re-export as EXR but the original problem still remains. It also doesn't explain the issue because the original 3D elements and the glows were all rendered out of the 3D program as tiff files with alpha, so a change in file format shouldn't make a difference at all.

This is the new EXR comp, see how transparent it is against the background plate, the colour is better in the EXR but the over aggressive transparency remains which is not present when I export it with the background plate as one comp (see second image below):enter image description here

This is the comp result if I export directly from my first compositing tree, see how the grey smoke is thicker and less transparent (ignore the duller front part):

enter image description here

This is how it looks if no alpha over factor is reduced, you can see how thick the smoke was originally:

enter image description here

$\endgroup$
0
$\begingroup$

Post 3:

Definitely something wrong with Blender (or the settings within Eevee).

I just tried exporting the meteor layer without any of the glows (hence all alpha over nodes were at the default 1 factor so no transparency on the actual 3D detail, just the usual surrounding alpha). Still the whole layer re-comps semi transparent no matter which colour profile is selected on the input image node or alpha on straight or premult so loss of detail is still present. Doesn't matter if I render as exr, png or tif all with alphas.

I need a solution as the original doesn't render even one frame after ten minutes hence having to break it down into semi comped layers for a second stage comp.

Edit: I've tried enabling the transparent setting under film in Eevee and Cycles and it makes no difference, the layer is still too semi transparent and the setting doesn't change how transparent it is rendered.

$\endgroup$
0
$\begingroup$

Post 4:

Just tried importing in Davinci Resolve, same problem, comp rendered layer is too transparent and colour is blown out, no matter which colour space profile I choose.

$\endgroup$
0
$\begingroup$

Post 5:

I've found a work around.

The EXR exported close to the comped look within Blender colour wise, but was still too transparent when re-imported back in for further comp. So I had to layer the original smoke trail underneath the EXR comp and it now looks similar to how it was in the first original comp, and now also renders much quicker.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .