1
$\begingroup$

In blender I deleted keyframes after 400, but my character still moving forward continously.

My character does not stop in any place. How I stop it? https://drive.google.com/file/d/1HyapnNHXoWfBAMFr7GfXsN1l6bqD_Gbd/view?usp=sharing you can see it after 400 please help

$\endgroup$
1
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Nov 4, 2022 at 0:13

3 Answers 3

1
$\begingroup$

I see the problem, the character keeps moving because it has a Follow Path Constraint added directly to the Armature object, that's why I couldn't see it in the Dopesheet.

Follow Path Constraint

The NurbsPath object is the one that handles the movement of the character, and the animation is in the "Evaluation Time" property that has a modifier in the animation curve that makes the position animation infinite

Nurbs Path Animation

To fix this problem you can go to the last frame of the animation, right click on the "Evaluation" property and select "Clear Keyframes", that removes the modifier causing the problem. In the same position you add a keyframe to the same property, and in the first frame you set the "Evaluation" property to 0. And to finish in the "Graph Editor" window you select both frames, press the V key and select the "Vector " to make the animation linear.

Custom animation

$\endgroup$
1
  • $\begingroup$ Last part which explaining graph edition can explain briefly that part I do same as you say but nothing happened $\endgroup$ Nov 4, 2022 at 1:57
0
$\begingroup$

I don't understand the problem very well, but if you mean that the cube stops following the character around frame 400, I noticed that the cube has a Child of constraint that is deactivated in that frame, deleting those frames solves the problem.

enter image description here

$\endgroup$
2
  • $\begingroup$ no i mean after 400 character keep moving forword without any command\ $\endgroup$ Nov 2, 2022 at 23:28
  • $\begingroup$ just saw things 1 to 4oo you will understand that there is no key frames after 400 why character moving forword $\endgroup$ Nov 2, 2022 at 23:29
0
$\begingroup$

As explained by @Leonardo: the issue is that your Armature is animated along a path via a curve modifier, but you didn't set any limit to that animation, so it keeps going virtually forever.

There are multiple ways to fix the issue. One destructive like @Leonardo's which consists of removing the modifier and manually rebuilding the animation with keyframes, and one non-destructive which consists of adding another modifier to modify the generated curve.

Destructive

  1. In Object Mode, select the object NurbsPath
  2. In ┃ Properties Editor
        ┗┅┫ Object Data Properties tab
               ┗┅┫ Path animation panel:
    Clear the keyframes of the Evaluation Time property via the RMB RMB menu or via ⇧ Shift⎇ AltI property
  3. Jump to frame 1, set the Evaluation Time to 0 and key it via I or clicking the key dot on the right side of the property
  4. Jump to frame 400, set the Evaluation Time to 399 and key it.
  5. If you don't want the animation to have an acceleration and deceleration, go in the graph editor, select the keys, open the handles types menu via V and chose Vector
    vector handles

Non-destructive

  1. In Object Mode, select
  2. In ┃ Graph Editor
        ┗┅┫ Sidebar
               ┗┅┫ Modifiers Panel:
    Add a Limits Modifier
    add limits
  3. Enable the Minimum Y and Maximum Y, leave the minimum at 0 and set the maximum to 399
    limits settings
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .