0
$\begingroup$

When generating a Mesh Circle with geometry nodes, the actual mesh appears very slightly smaller than both the input radius and the listed, final dimensions. This defective size is present in all further alterations made to the underlying mesh.

Am I missing something, or is this a bug?

Mesh Circle Issue

Mesh Circle Issue 2

The same offset is present on all sides of the circle. All transforms are 0 (except for a 90 degree rotation to set the circle upright) and I've also returned the item to the scene's origin to eliminate any possible confounding variables.

This is not just a grid issue, as any flat plane positioned such that it should sit tangent to the circle (in this case, at exactly Z 2.0") displays a visible gap between it and the mesh circle in all views.

Defect is also present using metric units. My use case requires that I match real-world product dimensions in imperial units.

Version is 3.3.1.

$\endgroup$
6
  • $\begingroup$ maybe use version 3.4? i don't see an issue there $\endgroup$
    – Chris
    Commented Oct 30, 2022 at 2:59
  • $\begingroup$ I was able to resolve the problem, unfortunately without revealing the underlying cause. My "solution" is below. $\endgroup$ Commented Oct 30, 2022 at 3:15
  • $\begingroup$ A mesh-circle is a polygon. The 'Radius' is from center to vertex. The distance from center to flat edge is shorter. If flat edges on an evenly-segmented "circle" are aligned to object XY, then 'Dimensions' will be less than 'Radius'. Does that have anything to do with it? $\endgroup$
    – Robin Betts
    Commented Oct 30, 2022 at 10:30
  • 1
    $\begingroup$ @RobinBetts Uh, no, if you create a mesh circle with 32 vertices, then it will certainly not be displayed with such a high resolution as it is shown here (apart from that, with 32 vertices, the horizontal and vertical points lie exactly on the X/Y axes, so this problem should not arise either). I rather suspect that a subdivision modifier is additionally involved. Of course, it is possible that the radius is somewhere below 2" (e.g. 1.999"). $\endgroup$
    – quellenform
    Commented Oct 30, 2022 at 11:49
  • $\begingroup$ You are correct that there is a subdivision modifier active (but not applied) here - an oversight on my part that could have potentially been the cause. It was not. I added the very same same subdivision modifier to the new object and the defect was not present. The radius was exactly 2.000". Input by hand. $\endgroup$ Commented Oct 31, 2022 at 1:14

1 Answer 1

0
$\begingroup$

Very interesting resolution. I tried a few additional things, including generating all other manner of meshes with this object and all of them retained the same, infinitesimal sizing defect.

I created a brand new object and attached the same node set, same properties, and magically the issue was resolved.

A thorough search of the original object's properties found absolutely nothing to distinguish it from the brand new mesh. No scaling transforms, no hidden properties, and the geometry node setup discards the input geometry so no relevance there. The only distinguishing factor I can think of is that the original object (and indeed the scene itself) was created in an earlier version of Blender (3.1).

Regardless, issue resolved. When all other troubleshooting steps fail, start fresh, I suppose!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .