0
$\begingroup$

Earlier I attempted to append two actions to this .blend file. The appended "Walk" and "Run" actions weren't animating properly, and the bones had to be rotated along the Y axis with Ctrl + R in order for them to work.

However, this broke the existing "Idle" action, which was built for the armature before it had its bones rotated. I've created a new .blend file to illustrate this:

A .blend file with the original armature and twisted armature placed side-by-side

The armature on the left appears to be the proper one, with the Z axis pointing upwards and the X axis pointing right. The "Idle" action works, but the "Walk" and "Run" actions do not.

The armature on the right appears "broken", with Z pointing down and X pointing left. The "Walk" and "Run" actions work, but the "Idle" action does not.

This appears to be an issue with the actions themselves. I'd like to avoid reanimating this if possible, is there any way to edit the "Walk" and "Run" actions so that their bones are rotated properly?

You can find the .blend file here!

$\endgroup$
4
  • 1
    $\begingroup$ Hello, from what I understand your problem is that you can't expect the same action work the same way on both the 2 armatures if their bones are not rotated the same way $\endgroup$
    – moonboots
    Oct 27, 2022 at 12:18
  • $\begingroup$ @moonboots Is there any way to fix the action so that it assumes that the bones are rotated though? $\endgroup$
    – MEATTAIL
    Oct 27, 2022 at 12:31
  • $\begingroup$ You could try to do it in the Graph Editor but I'm afraid it will be super tedious $\endgroup$
    – moonboots
    Oct 27, 2022 at 12:36
  • $\begingroup$ @moonboots In theory I should be able to scale the Y Quaternion by -1 on all the keysframes on all the bones in the graph editor, but it doesn't appear to do anything. $\endgroup$
    – MEATTAIL
    Oct 27, 2022 at 13:37

1 Answer 1

0
$\begingroup$

I couldn't find a solution no matter how far I looked or how hard tried, most of the posts I came across were unanswered so here's mine: I ended up reanimating everything.

Please make sure that your bone roll is set to zero before animating.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .