2
$\begingroup$

When I apply bevel modifier to the mesh, some vertexes merge to the Origin point of the mesh blowing up the geometry. There are no doble vertexes, faces, ngons. The Normals, Scale are correct. I tryed to change the position of the Origin Point. The result is the same... enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

I attache the link to the file below. https://drive.google.com/file/d/1QulB3sW5kMNUZb4YZKCqe0MFJ4UqFTPI/view?usp=sharing

It could help possible.

I have the same type of problem in the other mesh. enter image description here

If I delete some faces, the problem is solved. enter image description here enter image description here

$\endgroup$
7
  • $\begingroup$ Yes, it seems to come with the Bevel modifier, some setting there will be causing it. I guess there is something like a too high Amount or similar whereas part of the geometry are too close. But although you suspected it has something to do with the bevel you didn't bother to show the modifier settings in your screenshot... that's a pity ;) $\endgroup$ Oct 27, 2022 at 9:42
  • $\begingroup$ Okay, with the Amount that's set and Clamp Overlap enabled I can only imagine there are double vertices, flipped normals or any other geometry problems. In the question you say that you have checked for these options and there is nothing like that. Then I guess you should upload the file because without further inspection of the model it seems impossible to determine where the error is. $\endgroup$ Oct 27, 2022 at 10:17
  • $\begingroup$ Thank you for your answer. I attached two more screenshorts with open bevel settings. There are no close geometry. I turned on "Edge Lengh" so you can see the real size and proportios of the mesh $\endgroup$
    – Alex
    Oct 27, 2022 at 10:24
  • $\begingroup$ Thank you. I'll upload the file in a minute. $\endgroup$
    – Alex
    Oct 27, 2022 at 10:27
  • 1
    $\begingroup$ It woks! Thank you very much! You saved my day! :) $\endgroup$
    – Alex
    Oct 27, 2022 at 11:52

1 Answer 1

3
$\begingroup$

It's a combination of different settings that don't like to be combined, as it seems...

For example, to get rid of this strange artifact you can do one of the following things, depending on what is best for you to work on with the model:

  • disable Clamp Overlap (not necessary for this micro bevel, there's no overlapping)
  • or set Miter Outer to Sharp instead of Arc (won't see the difference anyway on the small bevel)
  • or close the side of the object (Does it have to be open? Filling the hole removes the artifact)
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .