0
$\begingroup$

I generated rigs by using Rigify for my animal models. My model is consisted by four different meshes. One is an animal shaped mesh with hair particles added, and this mesh is settle inside of the other animal shaped mesh without hair. There are also separated meshes of ears, which also has hair, and a nose.

When I try to move the model in pose mode, only the mesh without hair, ears and the nose are all move along the bones. But the mesh with hair is left behind, and it looks just like astral projection. What is the solution to make the two meshes move in tandem?

One thing that made the object with hair particles different from the others is that there is a Vertex Group set up for the hair. So I've changed the armature setting "Bind To" from "Vertex Groups" to "Bone Envelopes" in the modifier preferences for the four objects that make up the animal model. Now all the objects are aligned and moving with the movement of the bones once. But in this way, movement of the model is very very stiff. Even the tail doesn't come straight up. Is there any way I made it works well?

I am using Blender version 2.93.1. I have read past posts and tried to do the same thing, but either the versions are different or I couldn't figure out how to do the settings described here: Some meshes follow the armature and some don't -the-armature-and-some-dont

It would be helpful if you could tell me. Thanks in advance.

One mesh remained while other three moves

$\endgroup$
0

1 Answer 1

0
$\begingroup$

When actually setting the weights (Ctrl+P > With Automatic Weights), I overlooked the following warning:

Bone Heat Weighting: Failed to find solution for one or more bones.

So I "Disconnect Hair" in the particle settings for the mesh with the hairs not following the bones, then switched to Edit Mode and did a thorough clean up of this mesh. Specifically, I subtly simplified the mesh with Mesh > Clean Up to automatically sort out any independent or duplicate vertices. After that, I triangulated all the faces with Face > Triangulate Faces.

After this, I set up Automatic Weights again and everything worked fine! The cause was not because the hair particles were there nor the Mirror Modifier were not applied to the mesh, but simply that this mesh contained a jumbled mess that needed to be tidied up.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .