I'm using Blender 3.3.0 and I'm trying to render a simple image.

My problem is that it seems that Blender is not applying the number of samples I set in the "Max samples" box. If I set the image to render at 200 samples, it starts rendering normal, but at about 80 samples, the sample counter starts going very fast. It seems as if blender stops rendering at 80 samples and the samples counter just keeps going without the image being rendered or without more samples being applied to the image.

I've tried rendering the same image at 2000 samples, but I get the same result. The only difference is that the sample counter starts going fast at about 1500 samples. The rendered image looks grainy and it looks like it was rendered with very low samples.

I wonder if I accidentally pressed a key, because this is the first time I've encountered this problem. I rendered another image with the same version of Blender and it came out normal. I don't know if moved something in settings in the first blender file.

Thank you in advance.

This is a screenshot of the image rendered at 2000 samples and my settings:

[Rendered image1

My settings

Sample counter I'm referring to


1 Answer 1


Blender is doing exactly what you tell it to. You say (render) wait until there is less that 1% noise (noise threshold) or stop at 2000 samples. The lighting makes it hard for Blender to get below that goal (I'm sure you can optimize that) so it stops at 2000 samples.
Consider using denoise, since your setup is prone to noise and should benefit greatly from it.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .