0
$\begingroup$

While doing some photography compositing work, I've noticed that if you get any image through Blender's Image node, the final compositing suffers a noticeable degradation in quality. There is really no 3D rendering here whatsoever, it's just the image in pluged to the compositing out. Seems to have something to do with color management. Maybe I am wrong to assume Image node should give a 1:1 result, but I would like to know if there is a fix to this.

Both the before and after are screenshots of the real .png, as size was too heavy to upload. The original picture is a high res png with 16 color depth, but it pretty much happens the same with any image.

Screenshot before Blender

Screenshot after Blender's compositing

Node "tree"

$\endgroup$

1 Answer 1

2
$\begingroup$

Resolution does not seem to have anything to do with your problem. It will render Composite node at resolution set in your render output settings. What you observe happening with color is filmic color management filmic color transform being applied to the image.

You do not need to use Composite node to output an image but could use File Output node that saves images at whatever resolution is fed to it ignoring render output settings, so that might be more convenient. To fix the color, you need to switch to sRGB color space that is (for some mysterious reason unknown to me) called "Standard" in Blender:

enter image description here

You will also need to set Look to 'None' in order not to alter color of your image. That's assuming the image is in sRGB color space in the first place. It should be in sRGB or any other supported color space, which doesn't really leave you many options:

enter image description here

The best thing to do would be to convert your RAW images to linear color space before importing them to Blender in 16 bit color depth(setting it correctly in the image settings obviously). I think you could use Darktable for that. Then you could use filmic color transform more effectively. I would recommend using OpenEXR format for this.

$\endgroup$
2
  • $\begingroup$ That is exactly it. Thank you a whole lot. Didn't expect the render settings to affect something that would not be rendering at all, but it's nice to know that standard equals sRGB. I will look into your other suggestions as well. You are a life saver. $\endgroup$
    – stsiete
    Commented Oct 21, 2022 at 22:34
  • $\begingroup$ You do hit F12 or choose Render Image from the Render menu to render compositing result. It is rendering. How else do you call producing an image in CG?.. $\endgroup$ Commented Oct 22, 2022 at 7:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .