I'm making a Unity game asset with the UMA character system. I already created a base rig with Mixamo auto rigger and tried to add bones that will handle mesh adjustments (size of muscles, translation of vertices, face customization etc). And I have this annoying problem with one. Single. Bone. In the rest position (in which I'm adding additional bones) everything is fine...

model and armature in rest position

But when I switch to the pose position to check if everything works and needs some adjustments bone which is meant to control the bicep/tricep size on the right side is giving unexpected results.

model and armature in pose position

(Don't mind that envelops are pointing in weird directions, they are meant only for handling the character customization system, and they are not used in animations)

What is even more annoying is that on the left side everything works fine. I tried file cleaning, applying all transforms, duplicating bone that is working correctly, checking hierarchy, checking weights, deleting and creating a new bone with a different name... nothing works. Maybe there's something I missed or don't know? I don't like rigging and it's not my forte so I'm assuming I'm missing something.

I'm working with Blender 3.3.0 with no add-ons for rigging.

  • $\begingroup$ In your screenshots, the skeleton is still in Object mode. How are we supposed to see what the problem is, if it turns up only in Pose mode? $\endgroup$
    – BuzzKirill
    Oct 21, 2022 at 14:25
  • 1
    $\begingroup$ Okay, I managed to solve the problem. Apparently, I forgot to do one step for adjustment bones which is reparenting adjustment bone to its original self (which is the bone I'm duplicating it from). Source video if it's not comprehensive youtube.com/… $\endgroup$
    – Morgoth
    Oct 21, 2022 at 15:06

1 Answer 1


Okay, I managed to solve the problem. The correct workflow is:

  1. Duplicating the bone that is near the area you want it to affect from the rig that is used in animation
  2. Move it to the correct spot (optional)
  3. Change the hierarchy of the bone parenting it to the one you duplicated it from - select adjustment bone and original bone you duplicated it from/ctrl+p/keep offset
  4. Weight painting and such

I forgot about 3rd step entirely, so it was a hierarchy issue where my bone was parented to the wrong one. The new bone meant only for adjustments was inheriting wrong information which was causing an error.

Source video link in comments.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .