3
$\begingroup$

I have a model of a building with a sidewalk around it. Both show up when I switch to rendering mode in both Blender Render and Cycles Render mode. But: when I hit F12 for a final proper render, the building shows up -- but the sidewalk doesn't.

I've checked the normals and I thought the normals seemed pointed in the right direction. I've set the Clipping on the Camera to a high number. I removed all the materials from the sidewalk and added a new material-- the problem persists. I've exported the blend as an FBX file and the Sidewalk shows up fine in Unity. Just in final renders, it doesn't show up.

Here is a blend file: http://www.pasteall.org/blend/35247. I tried to destroy everything unrelated to the issue and label things in a clear way.

Thanks.

$\endgroup$
0
8
$\begingroup$

Look at the camera icons on the outliner. Click on the funnel icon on the top right and enable different filters.

When the camera icons are disabled, the object is disabled from rendering. To make it active click on the camera icon.

enter image description here

These icons are switches:

The Eye icon is to toggle object visibility on the 3D viewport.

The Arrow Icon toggles selectability.

The Camera Icon toggles rendering.

The Monitor icon disables the object in all viewports.

For more info refer to the blender manual

In older versions (2.79 or previous) the outliner the switches are here:

enter image description here

$\endgroup$
1
  • $\begingroup$ @twiststreet not at all, blender has way too many tricks. Happy blending. $\endgroup$
    – user1853
    Mar 27 '15 at 4:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.