I have an outfit that I am trying to give thickness with solidify. There are 3 related problems I am running into:

1) Solidify size can be controlled by a vertex group, but if set to 0, it still makes the new layer of faces, just with no distance between them and the old. I need different amounts of thickness in different areas, and in some places, I need no thickness. In crumpled areas with very small or no thickness, the back faces of the new layer clip through. Problem 1

2) I have a huge amount of unnecessary double verts in areas that don't need thickness.

3) In acute areas, the solidify makes split edges. Problem 3

I cannot change any vertices, or split the object. This outfit is being imported from Marvelous Designer, and has associated .mdd animation caches that will break if anything is altered. I am using the Mesh Cache modifier to load them, so anything I do needs to be after the modifier. Importing the .mdd directly onto the mesh as shapekeys would allow more options, but that isn't viable as I need to be able to bring in different animations without it breaking. I can make changes to it in MD.

I see from looking around google that problem 1 is supposedly solved by making the material backfaces transparent. But that doesn't seem to work? Transparent Backfaces

I have also found that triangulating the mesh (currently quads) solves 1, but is that the only way? If there is a way to access the verts created by solidify in a certain area, then they could be hidden, which would also solve 2.

It seems that 2 could be solved by something like a remove doubles modifier (which I see has been proposed in the past, but was rejected), and if that was done, then I wouldn't need to triangulate the mesh.

I have also tried using a deform cage based on an unaltered version of the outfit to control an altered version and so avoid the whole issue, but the results are inaccurate.

  • $\begingroup$ Try to use weight paint to control the thickness. $\endgroup$
    – Denis
    Commented Mar 26, 2015 at 21:17

1 Answer 1


It turns out the problem was simply Fresnel's strange behavior on backfaces. Since Fresnel is dependent on facing, back faces become very reflective. If you invert the fresnel on backfaces, then everything works fine. See here for how to do that: backfaces give strange results with fresnel node in cycles.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .