24
$\begingroup$

Using v2.73, cycles and a very simple scene: an array of cubes, no big deal. enter image description here

If I set the shader's material to transparent, the cubes in the foreground do become transparent but those far away in the back do not disappear completely and this strange dark things appear (visible in rendered mode and in final renders)

enter image description here

I've played with the clipping distance on the viewport and camera, but I can't figure out how to make those ghosts go away...

$\endgroup$
6
  • $\begingroup$ crank up the transmission in light paths in render tab $\endgroup$
    – Chebhou
    Commented Mar 26, 2015 at 19:55
  • 2
    $\begingroup$ it's transparency not transmission sorry, try again $\endgroup$
    – Chebhou
    Commented Mar 26, 2015 at 19:59
  • $\begingroup$ Related: blender.stackexchange.com/q/18857/599 $\endgroup$
    – gandalf3
    Commented Mar 27, 2015 at 6:24
  • $\begingroup$ I panicked when I saw you asked this question and felt so relieved after scrolling down and seeing an accepted answer! $\endgroup$ Commented Dec 29, 2016 at 18:38
  • $\begingroup$ Me as well hit the panick button, good grief thanks $\endgroup$
    – Peter
    Commented May 24, 2018 at 15:00

2 Answers 2

37
$\begingroup$

Go to Light Paths under the Render Tab and turn up the Max amount of transparent bounces until you have enough for every cube.

enter image description here

For 2.8* set the Transmission bounces in the Render section>Light Paths>Max Bounces

enter image description here

$\endgroup$
3
  • $\begingroup$ you saved my day $\endgroup$
    – Peter
    Commented May 24, 2018 at 15:01
  • $\begingroup$ transmission or transparency? $\endgroup$ Commented Jul 8, 2019 at 22:14
  • 2
    $\begingroup$ Although that answer has lots of upvotes, it mixes up Transparency and Transmission bounces, especially because when it says that from Blender 2.8* upwards you should increase the Transmission bounces. But that's wrong, this wouldn't help in this case. Also it doesn't give hints on the dependencies between Total and Transmission bounces. In the screenshot they both have a value of 12, which is okay. But if 12 wasn't enough, increasing only the Transmission bounces won't make a difference - whereas Transparency (which is what's needed here) would work when increased. $\endgroup$ Commented Apr 23, 2021 at 12:54
4
$\begingroup$

The reason is the Max Bounces setting for Transparent bounces under Light Paths in the Render Properties.

As it seems, you have a value of 0 there. I would rather suggest setting it to a much higher value like 64 or even 128. It doesn't increase the render time very much but you can avoid black artifacts when too many transparent objects are overlapping themselves. Also black artifacts in smoke simulations are much less likely to happen.

The problem doesn't occur in Eevee since it's not a raytracing engine and doesn't use the Light Paths settings for bounces etc. The background is still transparent since it is not "bouncing off" rays so it's not limited to that setting.

It is not necessary to increase the Total bounces, since Transparent bounces are independent from the Total amount while the other values are not. You'll find it here:

transparent bounces

Here is an example: When you have one plane with transparency in front of another object e.g. a sphere, the object behind it will be black in the transparent areas just like in your screenshot, because the Transparent bounces are set to 0.

transparent 0

If you now simply increase the value to 1, the sphere will no longer be black behind the plane. But if you put a second plane in the scene, the sphere only shows correct behind the one or the other plane. Where they are overlapping it has turned black again, because there are 2 transparent layers. You can imagine that using small values will quickly give bad results for example on tree objects holding lots of leaves with transparency.

transparent 1

$\endgroup$

You must log in to answer this question.