2
$\begingroup$

I've come across a Cycles issue where the disks of disk-shaped area lights are invisible in a rendered scene, but they are visible in a window with reflective glass material.

To put it another way, the light issuing from the disk-shaped area lights works fine, and the disks themselves are invisible when rendered--as they should be--with the exception that they are visible when reflected in a glass window. Why? Is there a way to fix this? Thanks. Blender 3.3.1, Windows 11

$\endgroup$
1
  • 1
    $\begingroup$ This is normal behavior. The reason you can't see lights in the camera is because they are not a 'surface' themselves, but they are seen reflected on all surfaces. Consider that if the light were not visible as diffuse or glossy reflections... what would they be doing in the scene? $\endgroup$ Oct 15, 2022 at 17:47

1 Answer 1

3
$\begingroup$

You could go into Object panel > Visibility and disable the Glossy option:

enter image description here

$\endgroup$
2
  • $\begingroup$ I was looking in the wrong place. Thanks! :) $\endgroup$
    – WilburPost
    Oct 15, 2022 at 17:33
  • $\begingroup$ @WilburPost Just be aware that this means the area lights also have no effect on glossiness. Which means, glossy surfaces will no longer reflect the light onto other surfaces. In the image above this would mean, if the icosphere is in front of a mirror, and the backside would only be lit by light reflected from this mirror, than it would turn dark because the mirror doesn't reflect the area light anymore. $\endgroup$ Oct 16, 2022 at 12:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .