I recently changed my system into Apple M1 and tried to work with some old project containing a 21600x10800 texture. Unfortunately when loading Blender (v3.3.0) reports error:

"Texture exceeds maximum allowed size 16384 x 16384".

I didn't have such limit previously.

How can I increase the maximum allowed size of texture?

Does the texture format matter?

Is it because of apple M1 system?

  • $\begingroup$ My guess is that Blender decreased the texture size limit in future versions to optimize efficiency in the software. Currently, I am not aware of any way to bypass or increase that limit. What image exactly are you using that is that large? You might be able to use a smaller one and tile it procedurally with shader nodes. $\endgroup$ Oct 14, 2022 at 12:49
  • $\begingroup$ i am using earth height map texture so the resolution of the texture directly impacts the details visible on the map, it is just a 'learning sketch' similar to BlenderGuru "Earth" youtube.com/watch?v=0YZzHn0iz8U . It "was working before" on my older machine, so it is kinda sad that i would need to downgrade Blender to get higher resolutions... $\endgroup$
    – mtx
    Oct 14, 2022 at 15:37
  • 1
    $\begingroup$ I can see now that this resolution problem only occurs under Cycles engine with GPU Compute enabled under M1 Max Apple, if i switch to CPU it works ok. $\endgroup$
    – mtx
    Oct 14, 2022 at 16:24


You must log in to answer this question.

Browse other questions tagged .