I'm trying to achieve some particle motion blur for a graphic I'm designing. Using cycles in v3.3, which comes with various blur options. I want to be able to control the blurring of different objects, even the the point of choosing how many frames to blur over, and a custom shutter curve similar to that found in Render Properties > Motion Blur.

By checking off Render Properties > Motion Blur I have the following:

No Motion Blur

However, I want to add in motion blur for many objects (particles and other objects). So then I turn Render Properties > Motion Blur on.

I have quite a wide filter (200 frames) to generate a blur path. Unfortunately this also acts on the dynamic paint > waves effectively removing the effect from my scene (which I want to emphasize as much as possible. Note that I have not enabled Object Properties > Motion Blur for the background plane. Sorta surprised me that it would be blurred as a result of being "off".

Motion Blur

To get to something much closer to not being blurred, I manually change the object blur modifier by turning on Object Properties > Motion Blur and ensuring the steps is set to it's minimum (1). Note that unless Deformation is checked, the waves will still be blurred. Interesting how you can turn on this blur to override the global blur (but still can't remove the blur window to 0 ahahaha).

No Motion Blur

I've never used the compositor before, but I've seen some answers suggesting to use the compositor with either ID Mask or Cryptomatte methods to generate the blur on a particular set of objects - I'm not sure how to go about setting up the compositor properly though, particularly

  • Setting up the necessary inputs on Render Layer node (such as velocity? or objects?),
  • How to create a "shutter curve" to shape the blur effects.
  • How to re-combine separately blurred images in the compositor for a final result

This answer had a start at trying to do some of these things, but I'm not sure it's quite what I'm asking, certainly not a direct mapping from the engine render motion blur.

Here's the .blend file with 3 scenes that generate each result.

  • 1
    $\begingroup$ Please share your blend blend-exchange.com ... BTW Object Properties > Motion Blur OFF works for me for object, the issue here is probably the Waves are not technically "object" motion, but movement of vertices (I didnt test it, just theory). If I understood you right, your issue is that my answer with compositor doesn't generates such "trajectory" for you, right? Probably you would have to render image sequence separately ... BTW2 for such trajectory probably try to search for particles or animated path (it depends on appearance of entire animation visual effect). $\endgroup$
    – vklidu
    Commented Oct 13, 2022 at 16:46
  • $\begingroup$ Yeah it's not so much about the current speed or velocity, but that it actually creates a blur over time that is positional - a "trajectory" for sure. I want to create different effects of the same nature. I've seen people use particle systems to create trajectory streaks, maybe this is a better solution - but I think it should be possible to turn off the blurring given to the background plane with dynamic paint. $\endgroup$
    – Mr G
    Commented Oct 14, 2022 at 3:45

1 Answer 1


Motion Blur

When Motion Blur (at Object Properties tab) is OFF means blur is not used for such object. When Motion Blur (at Object Properties tab) is ON it takes into account Scene's Motion Blur and can be controlled in Step field.
(Since step 1 is low blur you can see it quite clear, for value 7 it is fully blurred.)

Deformation ON - Enables motion blur for deformed meshes (See manual for warning.)


What you are experiencing here is probably limited functionality of scene motion blur, that calculates blur on object level, but your waves are generated by modifier on vertex level. And for that Deformation ON is essential.

I would expect object with M.Blur off, would be rendered with wave modifier as usual, but it looks like since Deformation is not an available for scene's M.Blur than it is not rendered at all.

So what you see on your second image is not extremely blurred wave, but ignored Displacement modifier.

If I'm right here there is not an option to adjusted better then what you already did and you would have go another way ... render object separately and composite renders back together or use for such trail effect Particle System or animated curve.

Particle System

I merged all vertices of "Electron.010" into a single vertex at centre, add PS to this object (if you don't need gravity, disable it), Source > Vertices.

Since Halo is not working under Cycles, you have to add a Cube covering entire trajectory and create a Volumetric material based on Point Density node for more details about setup see this thread

enter image description here enter image description here

With ColorRamp adjustment ... enter image description here enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .