3
$\begingroup$

I am trying to create a very simple product mockup using blender. I want to be able to save the actual product (cards) and the shadows as separate png files. I know this is possible, but I am just learning blender. Here is a link to the file I am working with: http://www.bestideabox.com/test.blend

Can anyone tell me why this is not working the way I am expecting?


EDIT:

OK; I have changed the blender file to represent the chosen answer and it does work. The shadows are saved to a separate layer. However they are different than when rendered altogether. I have placed the revised blender file here: Blender File Here is all layers rendered together: All Layers. Here is each individual layer: Cards and Shadows and here is the two individual layers laid on top of each other using photoshop: Merged Layers. As you can see the shadows layer does not line up at all. Infact they are a different shape all together. I also am having trouble exporting the plane texture by itself if anyone can help with that.

$\endgroup$

migrated from stackoverflow.com Mar 26 '15 at 2:30

This question came from our site for professional and enthusiast programmers.

  • $\begingroup$ Yes that is correct, but I should get two separate files in the c:\temp dir correct? I am only getting one. $\endgroup$ – user3167249 Mar 24 '15 at 18:11
  • $\begingroup$ As an alternative you can use the OpenEXR format. In it you'd be able to save different render layers in one file. $\endgroup$ – cegaton Mar 26 '15 at 4:02
  • 1
    $\begingroup$ related: blender.stackexchange.com/questions/16152/… $\endgroup$ – p2or Mar 26 '15 at 11:27
3
$\begingroup$

The file output node has two properties that determine the file that the image is written to, the base path (in red) which is the folder to save in and the subpath (in green) which could be a filename or a folder/filename combination.

enter image description here

In your example file you have two file output nodes that use the same base path and subpath, the second file gets saved over the top of the first one.

You also don't need two file output nodes, you can add multiple inputs to one node that have their own subpath and optionally image type settings. This can help as it prevents two inputs using the same subpath.

enter image description here

$\endgroup$
  • $\begingroup$ Now that I am able to render each layer separately I am trying to combine in photoshop and can't seem to get the cards layer to match the shadows layer like it does if I render them all together. Can you please take a look at the revised post. $\endgroup$ – user3167249 Mar 30 '15 at 20:13
  • $\begingroup$ It is preferred that you ask each new question by itself not add it to an existing question. The issue is the angle of the lamp, such an acute angle casts reeeallly long shadows. $\endgroup$ – sambler Mar 31 '15 at 13:40
  • $\begingroup$ Sorry I had thought this related to the topic already started. That being said I'm confused by your answer. If the issue is the lamp why would the shadows render differently in the output that renders all of the layers together? $\endgroup$ – user3167249 Mar 31 '15 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.