1
$\begingroup$

I have a wavefront .obj file and a sharp edge list which are mapped with the vertex index form the .obj file. Now I want to add some functionality in the .obj file based on the sharp edge list. But the problem is when I load the .obj file in blender, blender changes the vertex index. So I can not map the same edge list from the .obj file in Blender. Is there a way I can prevent Blender from changing the vertex index and keep them same as the original .obj file(e.g. in .obj file, vertex index starts from 1 and the index increases by one for each subsequent vertex)? I am wondering why Blender has to change the original vertex index rather than giving the index sequentially?

$\endgroup$
3
$\begingroup$

There is an option for Keep Vertex Order in the .obj importer. Use that and you should be fine.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.