2
$\begingroup$

I was trying to make a simulation where two blocks made of icospheres collided, one being completely obliterated, the other intact with pieces of the other sticking to it. I had the entire particle system ready to go, all the settings tweaked. But when i go to bake the molecular script, it gives be an error. My System is Windows Vista 32 bit and the version of the addon im using is molecular win32 v1.02 The error goes as follows:

Traceback [most recent call last]
File "C:\Users\\AppData\Roaming\Blender Foundation\Blender\2.7.3\scripts\addons\molecular_init_.py" , line 600, in execute mol_report =cmolcore.init(mol_exportdata)
NameError: name 'cmolcore' is not defined location: :-1

Image of the Error

Is it a bug with the Win32 version of molecular? I did not download the 64 bit version by mistake. I made sure of that. Also it works perfectly when i run it on my Macbook.

$\endgroup$
  • $\begingroup$ I experienced the same problem by not having installed the proper Microsoft Windows Visual Studio 2012 Redistributable. After installing it the error went away. $\endgroup$ – user15568 Jul 11 '15 at 0:53
2
$\begingroup$

The molecular addon (and the cube surfer from the same author) are not pure python addons, they also use a shared library that needs to be compiled and located in the same addon folder.

For windows this will be cmolcore.pyd which needs to be in C:\Users\<user>\AppData\Roaming\Blender Foundation\Blender\2.7.3\scripts\addons\molecular\ If the library file is there then you may have downloaded the 64bit version by mistake.

If you still can't get it running you may need to compile a version specific to your machine. You can find the source files on github, read the cython docs for how and if you have any problems compiling ask for help on stackoverflow.

$\endgroup$
1
$\begingroup$

As Pyroevil (the Molecular addon author) said in this Blender Artists post, you may need to install Microsoft Visual C++ 2015.

This is the solution for the non defined cmolcore.

$\endgroup$
1
$\begingroup$

Solved by installing the 64 bit version (1.0.3 version tested with official Blender 2.71 release) Iconmolecular windows64 v1.03 40.77 KB molecular windows64 v1.03

But running blender 2.79. Windows 10. Microsoft Visual C++ 2017 Redistributable

$\endgroup$
0
$\begingroup$

Have the same problem... My answer would be find the folder it was downloaded to and delete the folder "Molecular" inside of C:\Users\\AppData\Roaming\Blender Foundation\Blender\2.7.3\scripts\addons, and reinstall the 32-bit version. If you use a version of Blender lower than 2.70 than you will almost always experience problems. You can easily fix compatibility issues by installing a newer version at the website... to be a smartass. However, as long as the Blender Version is beyond 1.7.0, then you should be OK and you can run it properly.

To be able to answer any further concerns, you need to put cmolcore.pyd in the Blender Addons folder or HELL will it have problems! As mentioned above by the lovely sambler,

The molecular addon (and the cube surfer from the same author) are not pure python addons, they also use a shared library that needs to be compiled and located in the same addon folder.

This means that they need to be compiled, along with the CubeSurfer, in a subfolder inside of the addons folder (Or, at least, that's what it sounds like...). cmolcore.pyd stands for "Compiled Molecular Core", and Windows being Windows, expect errors. That's why the best of us are smart and make patches for these. You can try replacing the molcore.py in the C:\Users\\AppData\Roaming\Blender Foundation\Blender\2.7.3\scripts\addons\molecular folder with the cmolcore.pyd and see if that works. Expect trial and error, please.

$\endgroup$
0
$\begingroup$

I didn't want my folks deleting blender off the computer, so I downloaded blender on the Steam Engine Instead. If you don't want compatibility issues with python script-related addons, then use the Steam version (The Gaming Engine, register free, then download blender free) and you can get Steam HERE.
Then Download the Molecular Addon and install it from the .zip file in user Preferences. It seems to Suddenly work!

$\endgroup$
0
$\begingroup$

I solved it by just installing the 64-bit version. I chose the 32-bit version first without thinking. I don't know if I have MSVC 2015 though...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.