1
$\begingroup$

I bought a collection of models that all came in a single model file (bad form already, I know). So I started working on splitting the models into each of their own files. This is when I notice that when in textured view, there is some weird z-fighting going on.

To narrow it down, I selected a single face in part of a model, then selected connected with sharp edges as a separator, so I only got part of the model (which is shown in the video). I turned on x-ray to select a face to verify that I'm only selecting a single face, thinking that there may be duplicate meshes on top of each other. Nothing. I did a point merge with a very small radius, but nothing merged. I'm convinced that the mesh itself is not fighting with a copy.

Since it only happens in textured view mode, I cleared the material and created a new BSDF shader with no textures attached to it, which is what you see in the video. So it seems to rule out the shading.

I can't figure out what is causing this. Any ideas?

Face orientation/normals: face orientation

Strange z-fighting-like happening: z-fighting

Video showing the issue: https://youtu.be/PBJmexufsz8

$\endgroup$
4
  • 3
    $\begingroup$ have you try an Object Data >Geometry Data > Clear Custom Split Normals Data? $\endgroup$
    – moonboots
    Oct 11, 2022 at 7:16
  • 1
    $\begingroup$ This looks not like z-fighting, it appears to be a face normals artifact caused by some transparency. That's why it only shows on textured view. $\endgroup$
    – ruckus
    Oct 11, 2022 at 17:24
  • $\begingroup$ @moonboots Where do I find Object Data? Is that a menu option somewhere? $\endgroup$ Oct 12, 2022 at 18:46
  • 2
    $\begingroup$ in the Properties panel, bottom right panel by default $\endgroup$
    – moonboots
    Oct 12, 2022 at 18:52

1 Answer 1

1
$\begingroup$

Your model doesn't use transparency but you have set Blend Mode to Alpha Blend in the material's setting together with the option [X] Show Backface. That's a bad combo and causes the so-called sorting problem.

Quote from the documentation (Show Backside is the Show Backface option):

Show Backside

If enabled, all transparent fragments will be rendered. If disabled, only the front-most surface fragments will be rendered.
Disable this option to ensure correct appearance of transparency from any point of view. When using Alpha Blending this option should be disabled because with Alpha Blending, the order in which triangles are sorted is important.

To fix this uncheck the [ ] Show Backface option.

screenshot

$\endgroup$
1
  • $\begingroup$ Thank you! The model was imported from an OBJ file, so I'm surprised Blender set it like that. I suppose there must be something in the OBJ file that Blender looks at and uses for that setting. $\endgroup$ Oct 19, 2022 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .