1
$\begingroup$

I recently created a model to import into Unity, but when I did, the normals were all facing the wrong way. I did some searching and found that this was caused by having not applied the scale to the model. However, when I went and applied the scale to the model, any time I move the timeline or look at an old animation the model objects go everywhere and I have no idea how to fix it. I've removed the armature, applied location, rotation and scale. Does anyone have any idea what I might be missing?

Here's some screenshots to make it clearer:

Here is the model in blender with the scale not applied model in blender with the scale not applied

Here is the same model in unity - the normals are the wrong way model in unity

Here I apply the scale (I've also tried location and rotation) model with scale applied

And finally the model in unity again after the scale has been applied. The normals are inverted to the correct direction but the objects are not aligned correctly model back in unity

The model also gets torn apart in different ways in blender when I change position on the timeline but I'm not sure why
model in blender

Here's a model file without the scale applied, highlighting all and CtrlA > Apply scale makes the model parts jump all over the place as shown in the images. This happens usually after I change the position on the timeline

download the blend file

$\endgroup$
  • $\begingroup$ normals are flipped with Ctrl+N in edit mode, also if you can add screenshots or upload blend file to make the question clear $\endgroup$ – Chebhou Mar 25 '15 at 18:55
  • $\begingroup$ Image added, thanks. The problem was that before the scale was applied the normals were in the correct position in blender but not in unity. Some other people had this proplem and said that applying the normals would fix it. It fixed the model normals in unity but now the objects are all over the place $\endgroup$ – habanero Mar 25 '15 at 19:29
  • $\begingroup$ Sorry I meant by applying the scale, not the normals $\endgroup$ – habanero Mar 25 '15 at 19:37
  • $\begingroup$ the problem is the parenting relationship you have to disable the parent and apply scale than parent again , i'm looking for an easy way to this ? $\endgroup$ – Chebhou Mar 25 '15 at 22:40
  • $\begingroup$ Hi thanks for the answer but it didnt seem to work for me. I don't mind redoing some of the work, I was just hoping I could fix it instead. I might redo the rig and delete all any actions and see if that does the trick $\endgroup$ – habanero Mar 25 '15 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.