0
$\begingroup$

When the fluid bakes, it stays contained in an extrusion in the mesh as shown in the pictures. When debugging the obstacle, I found that it closed off a part of the mesh and the fluid stayed contained throughout the entire simulation.

Fluid contained in part of mesh

obstacle debugged, revealing the closed off section

https://drive.google.com/file/d/1GjKqrINdAtYRASEc-wmu5LDxmqbFeOGw/view?usp=sharing

$\endgroup$
5
  • $\begingroup$ Didn’t check normals? $\endgroup$
    – Chris
    Oct 9, 2022 at 14:53
  • $\begingroup$ Recalculated inside, nothing changed. $\endgroup$
    – Shrimps
    Oct 9, 2022 at 14:59
  • $\begingroup$ r u sure this is the blend file you made the screenshot of? if i bake your simulation, i cannot see your result....so pls add a blend file which gives the result you showed in the screenshot and not a modified one. thx. $\endgroup$
    – Chris
    Oct 9, 2022 at 15:25
  • $\begingroup$ just a hint: would be great if you add an information like "i am totally newbie in terms of flip fluid and modelling" so i could first search for the beginner mistakes...this helps us finding errors quicker. $\endgroup$
    – Chris
    Oct 9, 2022 at 16:40
  • $\begingroup$ @Shrimps Hi. Please don't post essential information like links, files download or additional details in the comments section where it can be easily missed. Instead edit it into your original post with the Edit button above. Comments are transitory by nature, can't be indexed or searched for and may be erased at any moment. $\endgroup$ Oct 10, 2022 at 20:52

1 Answer 1

0
$\begingroup$

ok, you made a lot of beginner mistakes in your scene.

First, "normally" you should apply scale and rotation, if you are starting simulations (at least with rigid body + cloth -> they wouldn't work if you had negative scales as you have here in your file).

Second, your normals were wrong on your plane.001. And just hitting "inverse" doesn't help if they are wrong. But...you can "repair" them by adding a solidify modifier to your plane.001 (i used thickness of 0.03). By this you get "automatically" blue faces and the simulation works then properly, if you "uncheck" the inverse for the flip-fluid obstacle settings.

result:

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you so much, I really appreciate the help. $\endgroup$
    – Shrimps
    Oct 9, 2022 at 22:05
  • $\begingroup$ You are welcome $\endgroup$
    – Chris
    Oct 10, 2022 at 4:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .