0
$\begingroup$

I always face this kind of issues in clothes after rigging. I have tried various ways by Ctrl+ J both the clothes (Upper & Lower) or bridging edge loops of both the clothes so that both the mesh can become single one and then rigged again but this kind of mesh deformation could not be avoided. Please check the screenshot. Body parts are not continuous those ends just after the clothes starts.Screenshot

$\endgroup$

1 Answer 1

3
$\begingroup$

When you are working with complex meshes like clothes, you can start with a base mesh of body, it does not matter if very simple, the important thing is the division of the mesh for more accurated weight calculation.

Base body mesh

Then if the cloth do not have the Armature modifier, you can add it without weight calculation by pression Ctrl+P and select "Armature Deform" directly.

Add Armature modifier

Then with body and cloth meshes selected (the cloth mesh needs to be the active object) go to weight paint mode, and on Weights menu press "Transfer weights", and in the options of transfer dialog, change the "Source Layers Select" option to "By Name". This add all vertex groups of the body mesh to the cloth mesh with their weights.

Transfer weights

Now you can see the results

Result of transfer weights Result of transfer weights

For better results you can smooth the transferred weights, to do this, with cloth mesh selected and in the weight paint mode, go to Weights>Smooth and increase the iterations a few times.

Smooth weiths

Also you can add shape keys during the animation process, to do this, go to mesh properties panel, and press + button on Shape Keys panel group. If there are no other shapekeys on the mesh, press the + button twice, the first is to add the basis mesh (Original mesh), and the subsequent is to add mesh modifications. You can add as many you needed. Then with the new shapekey selected and setted its value to 1 sculpt the mesh a little

Add shapekey

Now you can animate this

Animate shapekey

$\endgroup$
5
  • $\begingroup$ Your first advice works great. Thank you. Before getting your advices I had worked on the solution, however in a different way, as you were provided in the second part of your answer. Modifying mesh by shape keys is a great way to work with. I have tried the same by adding driver. In this case also I had failed. Although, now my problem has been solved through your answer, but for knowledge purposes I am sharing the screenshot what I have done in add driver settings, so that you can check and advice further, what I had done wrong. $\endgroup$
    – Tanmoy Roy
    Oct 9, 2022 at 1:10
  • $\begingroup$ At the value of ‘1’ in shape key the mesh was modified by sculpting as swon in screenshot2. However, the mesh could not be deformed in action as shown in screenshot3. Driver bone settings may be checked at screenshot3. In the driver bone I have also used thigh_ik.L, thigh_fk.L in place of DEF-thigh.L, but finally nothing works. For screenshots following links may be clicked. $\endgroup$
    – Tanmoy Roy
    Oct 9, 2022 at 1:10
  • 1
    $\begingroup$ The rotation you're getting in the driver is negative ( screenshoot ), just add a negative sign and that's it ( screenshoot ), you can also remove the multiplication by 8 in the evaluation since the rotation is evaluated in radians, with 90 degrees you get 1.5 or so, and you just need the value between 0 and 1 $\endgroup$
    – Leonardo
    Oct 9, 2022 at 1:41
  • $\begingroup$ It worked. Thank you very much. $\endgroup$
    – Tanmoy Roy
    Oct 9, 2022 at 3:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .