0
$\begingroup$

I am having trouble with my Blender refusing to show .py scripts. They are installing successfully with the below message

Modules Installed () from 'C:\Users\{username}\Documents\BlenderPlugins\io_export_gm\export_gm.py' into 'C:\Users\ROG Strix Gaming\AppData\Roaming\Blender Foundation\Blender\3.3\scripts\addons'

However when I am trying to search for them under the Blender Preferences Add-ons window, nothing is showing up (the one in the list below is a standard blender add-in and NOT the one I installed)

gm export add-in should have come up

I can also confirm it is in my AppData folder

All these add-ins were successfully installed but don't show-up

I tried a number of different fixes described on internet and also tried 5 different versions of Blender but nothing helped so far, can use standard add-ins only.

I am using Blender 3.3 in Windows 11 Home.

Any advise will be much appreciated!

$\endgroup$
4

1 Answer 1

0
$\begingroup$

When you use the "install" button, what it does is

  1. If it's a zip file: unzip it ;
  2. Copy the files to the addons folder while keeping their hierarchy structure ;
  3. Refresh the addons list ;
  4. Pre-fill the search bar with the installed addon's name to isolate it.

If the addon doesn't show up, then it could be any of these:

  • the zip or files you downloaded weren't meant to be installed or used this way (if even downloaded). In which case, you should refer to the addon's documentation to know how to install it.
    If you get them from websites such as github: prefer downloading any "release" provided by the developer instead of the repo itself.
  • the addon you downloaded is not compatible with that Blender version. This also could be mentioned in the addon's documentation, but you can also see it in either the main .py file or the __init__.py file inside the bl_info boilerplate, i.e. : "blender": (3, 3, 0),.
    bl_info example And if you don't find a bl_info, that probably means the next point:
  • you didn't download an addon to begin with. Some scripts are meant to be instead loaded in the text editor and run from there. Again, it's usually explained in the addon's documentation.
$\endgroup$
2
  • $\begingroup$ Many thanks @L0Lock! The issue was with the Version in bl_info section. As ssoon as I fixed it I can see the addon now! $\endgroup$
    – Anton
    Oct 12, 2022 at 0:28
  • $\begingroup$ If you manually just wrote a different version number in the bl_info, it might fix the addon registration, but it might not make the addon fully functional. Do if you get errors or missing features, please double-check any update on the addon and which version of Blender it is meant for. $\endgroup$
    – Lauloque
    Oct 12, 2022 at 3:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .