I have a problem with background transparency. In the viewport the background is transparent but after rendering it is black. I checked transparent in film and also render in RGBA but it's still black. Also add the image to photoshop to check if it is from my photo viewer but it is not. Does anyone had the same problem?

This is how it looks in viewport: enter image description here

This is while rendering: enter image description here

And this is the final image: enter image description here

I have no idea why it adds a black background

A screenshot from compositing nodes: enter image description here

  • $\begingroup$ And you saved it as a PNG or which format? $\endgroup$ Oct 6, 2022 at 13:39
  • $\begingroup$ So, are you using the compositor? If so, would you mind sharing a screenshot from the node setup there? $\endgroup$ Oct 6, 2022 at 14:19
  • $\begingroup$ Yes, just added it $\endgroup$
    – Mona_
    Oct 6, 2022 at 14:25

3 Answers 3


You're using a Lens Distortion node in the Compositor. This doesn't support alpha transparency and makes the background black. Effects like Dispersion work on all pixels to create the color distortions, therefore it needs an opaque image.

Of course you could take the Alpha output of the Render Layers and plug it into the Alpha input on the Composite and Viewer node. But in this case distortions that are exceeding the opaque area of the original image will be cut off.

A workaround would be to plug the Alpha output into another Lens Distortion node with the same settings as the first one. This way the alpha will be distorted in the same way and you can use this on the Alpha inputs of Composite/Viewer nodes.

Just be aware that semi-transparent areas resulting from this will be mixed with a black background. This might make problems with overlaying the image on backgrounds with brighter colors.

enter image description here

Since effects like dispersion are dependent on the image colors, overlaying a different background color than black also results in incorrect results:

dispersion transparent vs opaque

This is of course an extreme dispersion. But as you can see, with transparency you first of all have a less colorful dispersion, since it is semi-transparent. The other things is, with a white background added before the dispersion effect, the color would not be blue, but yellow.

  • $\begingroup$ Thank you very much. I didn't know it can effect the transparency. After removing the node it can be export without a background $\endgroup$
    – Mona_
    Oct 6, 2022 at 14:34
  • $\begingroup$ @Mona_ I'll edit the answer to give a workaround. You can have transparency with Lens Distortion, the problem is just it's mixing with a black background which can be problematic if you want to overlay a bright background withthe transparent image. $\endgroup$ Oct 6, 2022 at 14:49
  • $\begingroup$ @Mona_ Last edit for today ;) Just another example what the problem with dispersion on transparent background is. $\endgroup$ Oct 6, 2022 at 15:14

The composite node needs to have "use alpha" enabled.

enter image description here

You can find this node by going to "compositing" in the top bar and then clicking on "use nodes".

However, this checkbox should be enabled by default, so it might not be the problem.

  • $\begingroup$ If she wouldn't know where the compositing is and didn't enable Use Nodes, she would most certainly not have to go there and enable Use Alpha, because by default Blender uses the Alpha when set to RGBA and Film > Transparent enabled. Just sayin' $\endgroup$ Oct 6, 2022 at 13:58
  • $\begingroup$ I know, but there's no other reason I can think of. Besides, I said in my response that "this checkbox should be enable by default, so it might not be the problem". $\endgroup$
    – ColinT
    Oct 6, 2022 at 14:12
  • $\begingroup$ Use Alpha is enabled. I will add images in the question what it looks like. $\endgroup$
    – Mona_
    Oct 6, 2022 at 14:15
  • $\begingroup$ @ColinT That's why I voted the question for "needs more details / clarification." Because there is no information if the compositor is used, and there are other possible reasons like e.g. saving in JPG instead of PNG. I just wanted to say: if she used the compositor, the explanation how to enable it is redundant. $\endgroup$ Oct 6, 2022 at 14:18

When you save your .png, enable RGBAenter image description here

  • 1
    $\begingroup$ I quote from the question: "I checked transparent in film and also render in RGBA" $\endgroup$ Oct 6, 2022 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .