When I render my image, the render looks normal when viewed in Blender. However, when I export the image as a PNG, the photo becomes over-exposed.

I don't think the compositor has anything to do with it, but I might've just overlooked something so you be the judge. I just found out that Filmic is infinitely times better than Standard in Colour Management, and as far as I can remember, the problem started to occur after that change in colour processing, so that may very well be the cause.

But I'm on the edge since it still doesn't really explain the change in exposure when exported, so I'm open to suggestions and answers to explain this personal mystery of mine!


Screenshot of render in Image Editor

Raw PNG image of render once exported

Compositing nodes

Colour Management

Process of me exporting render if that helps

  • $\begingroup$ Just a quick test with creating a similar scene doesn't show any differences on my computer. Anyway, may I ask where you get the different images from? The first one, "Image of render in viewer" is a screenshot from the Image Editor in Blender I guess... and the second one? "Image of exported render as PNG" - is that the actual file uploaded here or is it also a screenshot from somewhere? The Image Editor in Blender as well for example? $\endgroup$ Commented Oct 5, 2022 at 10:24
  • $\begingroup$ Yes the first image, the "viewer", or Image Editor is just a screenshot; I only took a screenshot of the render and excluded everything else around it, so it looks like I exported it raw but I didn't. You can see the same image in the compositor and me exporting the render at the bottom. The second photo is the actual file, the PNG, that I exported which is not a screenshot. Sorry for the confusion, I just like the continuity of the image sizes of both renders/instances of the photo. Kind of ironic compared to the rest of the photos I provided though :/ $\endgroup$ Commented Oct 5, 2022 at 10:34
  • $\begingroup$ I was just asking because in the Image Editor when you open a saved image and go to the sidebar panel (hit 'N'), there under Image you can set a Color Space for viewing the image or check View as Render which alse makes the image look different. Of course this would only matter if the second also were a screenshot from Blender. $\endgroup$ Commented Oct 5, 2022 at 10:52
  • $\begingroup$ Oh okay I understand. I've found a sort of robust solution. In the Image Editor, when I click the Image drop down then Save, it brings up file explorer, and to the right you can configure the settings of the file type, colour, etc. However, if I click on "Follow Scene" under Colour Management and change it to "Override", I can manually change the exposure down to what I want it to be. Atleast this fixes the problem currently, but I'm planning for this project to be an around 5 minute animation, so manually doing each frame is unrealistic. $\endgroup$ Commented Oct 5, 2022 at 11:14
  • $\begingroup$ But for an animation you don't need to save each frame manually, you can set it in the output properties together with the path etc. $\endgroup$ Commented Oct 5, 2022 at 11:24

1 Answer 1


Problem and Solution found.

To summarise, when I rendered a scene the image looked fine, but once it was exported the image was over-exposed.

After back and forth, the cause and the solution of the problem was the difference in Exposure settings under Colour Management, on both Render Properties and Output Properties.

Due to me transitioning to Filmic, I changed the Exposure in Render Properties down to -1.7, and forgot about the Output Properties which was still on default (0). It should've changed with the Render Properties but since it was set on Override, it stayed the same as before.

So with self-explantory logic, I simply updated the Output Properties' exposure to match the Render Properties' exposure, and voilà, the problem was solved!

Comparsion of the two properties with contridicting exposure settings.

Comparsion of both Render Properties' and Output Properties' difference in Exposure.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .