0
$\begingroup$

Blender v2.92 and also same problem with 3.3, 2.83, 2.79b.

Example

This is a video of the bug in action: https://youtu.be/WlswYH3-4vs

There are some tri's that do not paint at all regardless of the angle of the camera. The mesh has no modifiers. The mesh has applied scale rotation and location. The face normals are correct. The unwrap is appropriate and has no flaws. I've tried triangulating and ortho cam view and neither worked.

The only way to paint onto those tri's is by painting on the texture itself in the image editor window, which is problematic because;

  1. some edges overlap onto different UV islands which would cause texture seems,
  2. the resolution of the brush changes between the two windows of image editor and 3D viewport,
  3. it's laggy compared to painting in the 3d space.

I can upload the blend file if necessary. This is not the first time I've ran into the problem and I've not been able to find a solution in the past. When this happened to me in the past I just gave up after find no results on google, getting no replies in the blender discord, and the same thing has happened this time too.

$\endgroup$
1

1 Answer 1

0
$\begingroup$

Thanks to dann on the blender discord. The problem was that the brush cavity mask was turn on. This is located in the Active Tool and Workspace settings > Masking > Cavity Mask checkbox.

Uncheck that box:

image

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .