0
$\begingroup$

I've been struggling with this for a while, whenever I export a model as a .glb, the rig and shape key animations are separated:

A list of animations as displayed in 3D Viewer.

Here you can see the armature animations playing without the shape keys:

The armature animations, playing alone.

Here you can see the shape key animations playing without the armature animations:

The shape key animations, playing alone.

And here's how the animation is supposed to look (ideally it wouldn't rotate when being exported as a .glb one can freely move):

The animation, with both armature and shape key animations playing at the same time.

How can I make Blender export these as a single animation, so that the shape keys play at the same time as the rig animations?

You can find the .blend file here! Thank you so much!

$\endgroup$

1 Answer 1

1
$\begingroup$

Looks like I got it! All I had to do was uncheck "Group by NLA track" in the export menu.

A view of the export menu with "Group by NLA track" unchecked.

You can find more information here.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .