0
$\begingroup$

I'm new to Blender and have some basic questions.

I was trying to build a simple loading animation with Geometry Nodes. For that, I arranged a Curve in the shape of an “infinity symbol” and solidified it. In the middle of the infinity symbol, it overlaps with itself.

Questions:

  1. Is it a problem when Meshes overlap with themselves?
  2. Is it a problem when Meshes overlap with other Meshes?
  3. How can I stop Meshes from overlapping with itself with Geometry Nodes?

I'm thankful for every answer and general tips from you. Thank you in advance!

Wireframe mode

Solid mode

enter image description here


Thank you for the quick answer, and sorry for the late response!

I don't really know how I could implement this into my file, but I found a way to upload it with blend-exchange.com. If you like, you can take a look.

The file is structured for “procedural purposes”, therefore there are a lot of mathematical nodes in it. You can find the node tree in the "BezierCircle".

$\endgroup$
1
  • $\begingroup$ There is no issue with overlapping meshes in case you render them flat shaded with single plain color. The issue arises when you incorporate shadows and more complex materials to the model. The infinity curve can be modeled in such a way that it is a continuous closed loop so you can use the Factor of the Spline Parameter to raise each curve point along Z axis to avoid intersections. $\endgroup$ Oct 23, 2023 at 7:25

1 Answer 1

0
$\begingroup$

Welcome to BSE,

I believe the problem you are experiencing is due to overlapping faces (as you've mentioned in your question). It's important to note that I do not mean intersecting faces, which is what I think you may have meant when you said 'overlapping faces' in your question.

To clarify:

Overlapping faces (or vertices) are faces that occupy exactly the same space as another face. In these cases, Blender is unsure which face should be visible, and so you get some strange results. For geometry that has not been generated using procedural method, the problem of overlapping faces can be resolved by simply moving one of the faces by a tiny amount.

Intersecting meshes, whether multiple objects intersecting with each other, or a single object with intersecting meshes, do not represent a problem by themselves.

However your geometry is being generated using a procedural method (geometry nodes), and the resulting mesh has an identical 'thickness' all the way around, resulting in the problematic overlapping faces.

It's difficult to suggest a solution to your issue without taking a look at your geometry node tree, but I suspect varying the radius of the curve using the Set Radius node may be the answer. You can change the radius of various points along the length of the curve, so that the resulting mesh has a different thickness at different parts of the curve.

For example, below I am using the Spline Factor of a Spiral Curve to set the Radius of the Spiral Curve. The Spline Factor provides a range from 0 to 1 representing the start to the end of the curve.

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .